'Omeka_plugin_AbstractPlugin' not found error

Good morning,

I am troubleshooting an error I’m getting concerning plugins.

I am getting an “Fatal error: Class ‘Omeka_plugin_AbstractPlugin’ not found in /var/www/html/servername/plugins/AdminImages/AdminImagesPlugin.php on line 16” error.

We have installed these plugins: Carta, CSSEditor, CsvImport, FacetByMetadata, and Geolocation

We have several Omeka instances up and running fine but this is the first one with Omeka 2.4.1

I would appreciate any troubleshooting advice you have.


1 Like

From the error message, it looks like there’s another plugin called AdminImages. In that plugin’s AdminImagePlugin.php file, I’ll guess that there’s just a typo, with lower case p, in the class declaration.

Probably something like extends Omeka_Plugin_AbstractPlugin with the capital P should be in line 16.


You just need to change line 15, Omeka_plugin_AbstractPlugin to Omeka_Plugin_AbstractPlugin.

change p to P, line 15, file AdminImagesPlugin.php

1 Like

Just had this same error and this fixed it, Thanks so much!