Omeka displaying image urls instead of images

Hi all, I just recently encountered a new problem with Omeka. The other day I activated plugins to display PDFs (Docs Viewer, PDF Embed, and PDF Text). I then deactivated Docs viewer a little while later. After making this change with the plugins, I started having trouble with new jpegs. The old images are fine. When I upload a new jpeg, the public page displays a file name link to the image instead of the image itself, for example: test.jpg. Once you click on the file name, you can see the image.

Example:
http://129.7.224.3/items/show/3228

I went back and deactivated all the PDF plugins, since that was the only change I had made, but it’s still not working. I am working with Chrome, but tried re-uploading the image on Firefox and it gave me the same error. I also emptied by computer cache. Any ideas? I am not getting any error messages. I do not have access to the server, but I can ask IT to reset it, if necessary.

Thanks!

This means that ImageMagick isn’t working on your server. Does the “Test” button next to the ImageMagick path setting on the settings page work?

It shouldn’t have anything to do with the PDF plugins you mentioned, though. Are you sure the issue started at the same time?

1 Like

Not sure if this helps but I had a similar probelm loading some jpegs. In my case I fixed the problem by reducing the size of the image.

I just checked the ImageMagick path and you are correct! It isn’t working! It turns out it was just a coincidence that I didn’t notice it until after I toggled the PDF plugins. Our IT recently updated our instance of Omeka, so that must be when the path was changed. Thank you!