Omeka Classic, Scripto, MediaWiki question

I am in the process of adding MediaWiki to an Omeka production server with my versions listed below. Will MediaWiki be compatible with Omeka Classic 2.2.2 and, if not, what version of MediaWiki should I install?

These are the current version numbers:

Omeka Classic version 2.2.2
Scripto plugin version 2.2

Thanks!

Rick Neal