Omeka Classic Importer is throwing up errors

I have used the Omeka Classic Importer to seamlessly import items and collections into Omeka S sites. I tried to use it today, but it keeps

throwing up errors. I don’t know what I am doing wrong. I’ll attach a screenshot of what I have been trying so far.

Hi @Jerryl ,

Just looking at the screenshot, it looks like you might need to replace your API URL on that screen with an API key.

To generate a new API key, you simply:

  • Go into your user account in Omeka Classic
  • Navigate to the API Keys tab within your user account
  • Create a new key by giving it a label and submitting the form

Just to clarify, you don’t need a key unless you’re trying to get nonpublic data from the source site.

But having the URL in there will definitely be a problem. This looks like your browser maybe incorrectly auto-filled the URL into that box?

1 Like

Thank you both for the responses. It seems I might have conflated the API URL endpoint and API keys as the same value. It works now.