Omega classic suddenly stopped working

Hey dear People of the World,

Ininstalled Omeka Classic successfully in January for an university project.
All worked and we created a Neatline exhibition.

Now my lecturer wrote me that he can’t reach the side.
The error message says:
„ Omeka has encountered an error

To learn how to see more detailed information about this error, see the Omeka Classic User Manual page on retrieving error messages.“

We made sure that everything worked when we submitted the project, which it did.

Has somebody any ideas what could be the problem?
We didn’t do anything. No updates, no nothing :sweat_smile:

Have you tried the above?

No one can help you basing on this general error message. You need to paste more detailed info.
When you uncomment the line in the .htaccess file (as described on the linked page) you will get more detailed info about the problem, that makes possible to solve it.

There is always is a reason :wink:

I tried to follow the steps mentioned in the link which leads me to omekas “retrieving error messages”-side,

This is the steps to do:

To turn on robust error messages, take the following steps:

  1. Go into the files for your Omeka installation on your server. You might do this using a FileManager from your hosting service, or SSH.

  2. Open the .htaccess file in the root directory of your Omeka installation. The root is the main directory, where you’ll also find the plugins and themes folders.

  • You might need to turn on “see hidden files” in order to see the .htaccess file. If you’re not sure how to do this, look in the directions for your file manager.
  1. Find the following line, and uncomment it (that is, remove the # sign): #SetEnv APPLICATION_ENV development. When you are done, it should read SetEnv APPLICATION_ENV development.
  • You might need to download the file in order to edit it. Be sure to upload the edited version and replace the older version.

the big big problem is that i cant delete the .htaccess file. I managed to download it and edited it, but i cant replace it. It is not able to delete it.

Another Problem is that i want to do a backup of omeka, but i cant even do that hahaha.
Everytime I try to do:
mysqldump -h localhost -u username -p omeka_db_name > omeka_db_backup.sql

the system is saying:
-bash: omeka_db_backup.sql: Read-only file system

and i also cant enter mysql.
everytime i try it says:
ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)

i am playing with the thought of completly setting up omeka new.
is there any possibility that i can save the project we did with neatline?

i wanted to download the database, but i dont find it.
i use WinSCP to upload an Download since i cant manage to do it via console commands.
but i dont find the database there :confused:

Do you run this server yourself, or do you have a host or IT you can talk to?

That error “read-only filesystem” is saying the filesystem you’re trying to output the backup file to is mounted read-only. You might just be trying to save it to some read-only location but if it should be somewhere you can write to you might have a problem with your server’s filesystem or storage. This “read-only” problem probably also explains why you can’t replace the .htaccess file (and maybe the Omeka problem itself).

It’s possible to remount a filesystem read-write, but you might be looking at needing to repair the filesystem or something like that also.