OAI PMH Harvester : wrong URL


I encouter a problem with links to harvested documents. I harvested a set from Gallica, it worked fine but when I click on the link to a document I have a “404 Not Found” message (the URL : https://bibnum.obspm.fr/document/http%3A%2F%2Fgallica.bnf.fr%2Fark%3A%2F12148%2Fbpt6k655014). The URL seems to be wrong, as it starts with our website domain name. What can I do to correct it ? Our website is only available from a local instance yet.
When I try to harvest our own OAI PMH repository, all the links work.

Can anyone help ?

Thank you for reading.

The harvester doesn’t really make links by itself, so I don’t think this is a harvester problem per se.

It looks like this is some sort of conflict between the Identifiers produced by the OAI repository you’re harvesting from (which are URLs) and some other plugin you have installed on your Omeka that uses the Identifier to make the link to the item (rather than Omeka’s default of using an automatically increasing ID number). There seems to be some problem with That’s my best guess.

Thank you for your answer ! I solved the problem by disabling the “Clean URL” plugin.