Number Data Types

Since updating to 4.0 I get this message on the Item Browse pages of my sites:
Warning: array_merge(): Expected parameter 1 to be an array, null given in /var/www/html/modules/NumericDataTypes/Module.php on line 347
When I deactivate the Numeric Data Types module the message disappears. Any ideas?

Thank you for bringing this to our attention. It’s actually a bug introduced in Omeka S 4.0. We’re currently working on a fix that will necessitate an upgrade to S and affected themes.

By the way, what theme or themes are you using on these sites (I believe this is a “public side” problem only)?

Thanks - I’m using the Foundation theme.

Please try out the new Foundation version 1.3.3, which should resolve this issue.

Just want to mention that I’ve found the same error when using Center Row 1.8.0 but not The Daily 1.7.0.

Thanks @kprtll, I believe we’ve already found that issue as well; we’ll let you know when there’s an update for Center Row that addresses this.

that worked! thank you for the quick resolution

@kprtll Center Row 1.8.1 is out, which should fix this problem.

1 Like

This is fixed in Issues in php 8 by Daniel-KM · Pull Request #34 · omeka-s-modules/NumericDataTypes · GitHub independantly from themes.

Just to clarify what’s going on here: the bug people have reported in a few themes arises from the combination of themes using older code to handle user sort selection, a core bug in that older function, and NumericDataTypes having code that’s used to alter the sort options to include numeric-based sorting.

We’ve been releasing updates to the themes to switch them to a newer, 4.0-specific sorting function; switching to that function avoids this problem on its own. We also have a fix pending to the core for an eventual 4.0.1 bugfix release to resolve the issue there, which will make usages of the older sorting function not cause this problem. Daniel, as he mentioned above, also sent an update to NumericDataTypes that avoids the error through a change there.

Any of those three fixes will prevent this bug from arising. We went with theme updates first because they’re generally a little simpler for us to push out and for people to apply, but all these fixes will be released.

The fix to this problem from the Omeka S core side is now released, in Omeka S 4.0.1.