Not redirected to Omeka configuration after installing


#1

Hi, all. I am following the instructions of the tutorial at the following link:

When I get to the step where it says “Access Omeka Classic Web Interface” and I open my browser to http://example.com, I don’t get the Omeka Classic configuration page, as I should. Instead, I get a generic page saying “Example Domain: This domain is established to be used for illustrative examples in documents. You may use this domain in examples without prior coordination or asking for permission.”

I’m sure there’s something obvious that I’m flubbing, but I’m still flummoxed. Please be kind and send me your suggestions.

Thank you.


#2

The tutorial is a little strangely written at that point… what it’s intending to tell you to do is to go to the URL for your site, whatever that URL is. example.com is just, well, an example.


#3

O.k. So, where do I define my site’s web address? Just by changing entries in configuration files? Sorry. 'Total newbie here.


#4

O.k. So, when I go home to 127.0.0.1 I get a page showing a message saying “It works!” and it’s a default Ubuntu Apache2 page which I should replace with whatever I want my Apache2 server to show. 'Guess I need to replace that page with a page that was included in my Omeka installation. Right?


#5

When I go to “127.0.0.1/omeka/” I am redirected to “127.0.0.1/omeka/install” where the following message is displayed:

“Omeka Installation Error mod_rewrite is not enabled. Apache’s mod_rewrite extension must be enabled for Omeka to work properly. Please enable mod_rewrite and try again.”

However, I ran the command “a2enmod rewrite” and I got the message “Module rewrite already enabled” printed in the terminal emulator.

Any ideas?

Thanks for any help you can offer.


#6

This error can happen if you don’t have “AllowOverride All” set for your document root in your Apache settings (or if you previously enabled mod_rewrite but hadn’t restarted Apache since then).