Not able to finish Omeka-s installation


#1

Hi,

I’ve been trying to install Omeka-s for about 2 weeks now, and still can’t get it to work and I’m not really sure where I went wrong, so I’m going to lay out what I’ve done below and I’m hoping you can tell me what I’m missing.

I am using Cpanel as my web host and uploaded the omeka-s zip file to it - and extracted it onto a folder called omeka-s within my home directory . (as can be sseen below)

I created my database, user name and password and then inputted it into the database.ini file - (not sure if i should be inputting anything into the port, unix socket, and log path?)

user = “daniel”
password = “daniel”
dbname = “i1896929_s1”
host = “localhost”
;port =
;unix_socket =
;log_path =

Finally I tried accessing the admin page by going to: [myurl]/omeka-s/admin - as this is the folder that the installation is saved within my file directory, but nothing happens.

Now, the only thing I can see affecting this is that there is a wordpress web page associated with my url so I can’t just type [myurl]/admin because that takes me to the sign in page of my wordpress account. So could this possibly be the problem?

Other than that, I really can’t think of anything, so any help would be really appreciated.

Thanks!


#2

I’m not sure you’re putting the files in the right place… it should probably go under “www” or “public_html” I would imagine.


#3

Typically in Linux systems your URL would be accessible if you place the omeka-s folder inside the “public_html” folder, and then went to the URL using the user-space notation. Something like:
http://www.mysite.com/~myusername/omeka-s/

You should see the omeka login screens at that point.

Hope it’s helpful!


#4

Thanks so much for your replies!

So I actually tried doing both suggestions of putting the file under “www” and “public_html” and I either get redirected to a "page not found " page on the wordpress associated with my website or I get a

This page isn’t working
www.website.ca is currently unable to handle this request.
HTTP ERROR 500

So again, I am stuck. Could there be anything else that I am missing?

Thanks!


#5

If you’re dropping the file into public_html and you see an error 500, you’re making progress. 500 type errors indicate something is wrong on the server end. To track this down, you’re going to want to explore your server log files.

I would check with the web host and see if they can provide you with information about viewing your web server logs. It’s possible you don’t have one or more of the required php modules installed on the server.

Cpanel has a support forum you can use (I don’t know if I can post links, but you can just google for cpanel support forum and it should be the first result) to ask for help finding logs, if needed.

HIH,
Kevin


#6

Also, you can follow the instructions here to enable error logging to the web interface for more information:
https://omeka.org/s/docs/user-manual/errorLogging/