Neatline Custom Layer not loading

Hello
I was hoping someone might be a familiar with a issue I am having with Neatline (apologies if I have selected the wrong forum section, this is my first post)
I am doing a fairly basic undergraduate project and have used Neatline and Omeka several times before. However, for some reason my custom base layer will not load when published, and in editing mode none of the tools (points, etc) are even visible for me to use. It started after I went into the HTML of one of my points to seperate a paragraph of text, but seems to happen on every site I try to make. I have tried using both the original address and a custom imgur address for my base layer, and have tried both with and without a layer option of openstreetmaps. I have tried in both firefox and chrome and on both a chromebook and PC. I am totally stumped and need to get this assignment done. I have attached screenshots of what I am seeing, and any advice would be much appreciated

Hi there,
One potential issue may be with the custom map and you might doublecheck your coordinate system.
You could also trying removing your custom base layer to see if that resolves the issue; if so, then there is an issue with the custom map.

Neatline’s user manual.

Good luck!
Robin