Multiple first-time problems with CSV importing

I am having several problems with CSV importing for the first time:

First, I am able to import the file, but I can’t find the items when I do an item search. I think this means the file didn’t import correctly. Am I right?

When I prepare for a CSV import, I know that it requires a column delimiter. What does that mean I need to do to my Excel spreadsheet? Do I put commas at the end of each cell to serve as a column delimiter? By the way, I have already made sure I had double quotes around text, and I selected the default delimiters.

When I try to map columns to elements, I am missing an element for my “File Name” column. Should my file names be mapped to “Identifier”? In other words, I’ve mapped “Identifier” to my Identifiers (such as jsg_2020_03_01_a), but I still have my file names (such as jsg_2020_03_01_a.jpg) to map. And I don’t see an element for file name.

Is it ok not to map some of my columns to elements if I don’t want that information included? Or do I need to delete those columns in my spreadsheet first?

Also, should I import my images using the DropBox plugin before I import the CSV metadata? How do these two link together? Is that done by checking the “File” box for the element on the mapping page?

I know these must be very basic questions, but I’m just not understanding the manual. Thanks in advance.

On the “column delimiter,” you don’t want to add anything to your Excel spreadsheet. When you export a sheet as CSV, Excel will add the delimiters and quotes and things like that for you. The default settings should be fine there.

It’s OK to not map some columns if you don’t want to put that particular information into Omeka. You can just leave those columns out when mapping, you don’t need to delete them from the sheet.

  • When you finish your CSV Import, the status tab will tell you the number of sucessfully imported or skipped items.
  • If you export your Excel file (or Google Sheets) as a csv file, it is comma separated as default. So you don’t need to do anything to your cells and just leave the default delimiter in CSV Import.
  • Where the delimiter might matter is if you have more than one value for a Dublin Core field (eg, Creator) that you would enter separately if you were adding items one by one. Eg, Barack Obama | Michelle Obama. This entry uses the pipe “|” as separator so in Omeka, I’d set Element Delimiter to the pipe character. If you do this, you don’t want to have your cell values in double quotes around the text or it will ignore the separator.
  • It will ignore unmapped fields.
  • To import the media file (and not just the metadata), you will need to specify the full file URL. You can specify a public URL (ie, not behind a password) and map that to the ‘File’ box . See plugin instructions: https://omeka.org/classic/docs/Plugins/CSV_Import/ There’s no need for a File Name column - it wants the File URL.

Thank you for your help!

You both have answered all my questions. Thank you so much.