Modules: Error: invalid config/module.ini file

Thanks in advance for your patience. I am a very beginning beginner.

I installed Omeka S (actually, my hosting company installed it).
I created some items, an item set, and a site, and it all worked.
I tried to add the CSVImport-2.3.1 module and the CSSEditor-1.3.0 module -

  1. I used FTP to put the zipped files in the modules folder
  2. I unzipped the files
  3. the modules appeared in the Omeka admin panel, but when I try to use them,
    I get the error message: invalid config/module.ini file

I saw in a previous post that you suggested checking the file/directory structure of the modules or the permissions. My Omeka installation address is:
www.omeka.mypage.org
Could that be the problem? If so, do you have suggestions on how to fix it?

If the permissions were not entered correctly when my hosting company installed omeka, do you have suggestions for common errors that I can look for? Would the other tasks (creating items, item sets, and sites) work if the permissions are not correct?

Thank you.

Peggy in ATL

Can you share a screenshot of the admin panel showing the problem, and also of the FTP or whatever file manager showing the contents of the modules folder (and one of the modules you tried adding)?

Permissions problems are a possibility, but it’s also possible to just have files in the wrong places, things like that. The “permissions” problem mentioned here would be specific to the module files you’ve added and probably not related to your host installing Omeka S.

Here are the screenshots that you requested-
My Omeka admin panel showing the Modules tab

And here is the panel from my FTP program showing what is in the Modules folder

I uploaded all the modules that were of interest to me, but I only unzipped two, CSSEditor and CVSImport.

Here is a screenshot of the online manual about the level of the directory on my hosted account. This is one of the things that I don’t understand.

My Omeka installation is at:
www.omeka.mysite.org
So it is up a directory level from
www.mysite.org

Is that a problem?

Thank you.

Hi @PeggyATL, You just need to remove the version number from the folder name. In other words the folders should be CSSEditor and CSVImport,

@fackrellj is right that the folder names should just be the names of the modules, without the version number added on there.

I’d add though, that the way we package the zip files, those numbers aren’t in there. You might want to look inside the “CSSEditor-1.3.0” folder for example. I suspect it might just itself contain a single folder called “CSSEditor.” If that’s the case, what you need to do is actually bring that “inner” folder out so it’s sitting directly in the “modules” folder and not one level “deeper.”

Thank you both so much! You are both correct.

I found the correctly named folder inside the folder with the version number. As soon as I moved it into the modules folder, it installed easily!

Now I get to practice using it :smiley:

Thank you!