Missing content of one element (Creator) after importing using CSV import

I have imported my metadata using CSV Import. Everything appears perfectly except my content for “Creator.” Nothing appears under Creator when I look at Edit Item, and the element does not appear in public view. I am using Creator as a column in my csv file and have mapped it to the same. I’ve tried importing several times with and without automap without luck. I checked to make sure that Creator was not hidden. I even tried retyping my column header in Excel! I’m wondering if some installed plugin is messing it up or if I have a setting wrong. What should I try next?

Thanks in advance

Can you share the CSV file you’re using? Maybe there’s some problem with that column?

Here is the link

Thanks!

I noticed some of the fields in Creator column are empty, but I’m not sure whether that could cause the problem since I am not familiar with CSV Import plugin. You might try typing in any placeholder value (to be removed later) and check whether it works.

I’m not seeing the cells that you are referring to. Could you please give me a row number(s) so I can try it?

Thank you!

I see them now! I will try with placeholders

It worked! Oh thank you so much, Daniele! The items I were checking just happened to be the ones with the empty cells for Creator.

:grinning:

Glad it solved your problem.

You may want to open an issue on the GitHub page (https://github.com/omeka/plugin-CsvImport/issues) about it, as it might help developers.

There’s also an improved version of the plugin (https://github.com/Daniel-KM/Omeka-plugin-CsvImportPlus), you might want to check whether the issue has been solved there.