Max allowed packet size error for SimplePages

Hi all, getting the following error when trying to upload a table (673K) into a simple page:

Mysqli statement execute error : Got a packet bigger than 'max_allowed_packet' bytes

exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli statement execute error : Got a packet bigger than 'max_allowed_packet' bytes' in 


I googled and it says to change the max allowed size in the mysql conf file on the server, but there’s nothing clearly set in there, and I’m actually not sure this is the issue anyways (given that the simple page is flat text of under 1MB I would think that the server default is higher than that).


1 Like

max_allowed_packet is indeed a MySQL setting, and the default value has historically been pretty small, around 1 MB.

It would be something you’d have to change in the my.cnf file for your MySQL server in the [mysqld] section. Omeka can’t do anything about it itself.

1 Like

That worked, thanks! I just added a line in that said max_allowed_packet=256M and restarted the service on the server. You can see the variable in phpMyAdmin but for some reason it only changes when you directly edit the conf file and restart.