Making URLs Active Links

I have several created fields that contain links. When I import using CSVImport, the URLs don’t display as active links, even if I have checked the HTML option. There are literally hundreds of fields entries like this. Is there a way I can do this automatically?

Hello.
You might try Omeka Classic - Clickable Links Plus plugin and see whether it helps.

Hi, I’m afraid it didn’t help. This is a screenshot of the plugin:


Is there something I should do to the config?
Regards, Randye J.

The plugin seems to be correctly configured.

Could you share the url to one of the pages not correctly working?

Yes.
https://spirituals-database.com/omeka/admin/items/show/26134

Both the Audio and Video Link URLs should be active.

Hi Randye.

I’ve just copied your URL (by the way: the link you provided is going through your Admin interface, so there’s no way to see that Item without the proper username and password; nonetheless, I could find that specific Item in the public interface) in an Item’s field in my test site and it works correctly, as it should.

So, I wonder whether the problems is connected to the specific fields you’ve created (audio and video). Could you try adding one of those URLs to a default DC field (anyone, f.i. Relation), enable it in the plugin config page and then check whether it renders correctly?