List of sites configuration not working

So now im working in a HUB for my difernt sites, but in trying to find a way to keep them all ordered it just doesnt let me. I put alphabetical order and it doesnt work:

The order they load is this one:

Im using Omeka 3.2.3

If anyone can help me i would apprecieted a lot


If you go to “Sites” in the admin, the browse page listing all your sites, are they shown in the expected order there?

Nope, the order in the sites list is 3 , 2, 1, 4

i’ve tried changin the names to a b c d of the sites, the descriptions, and de tag, and the order is still the same

also i tried to change the max number of sites and it doesnt work either

the only thing i did, i moved the file that generetes the list of sites to the theme

and added a class to the lists that have a thumnail and the ones who doesnt,

But even deleting the code and letting it the same way i found it it doesnt work any of the configurtions i give to it

Can you try in another site, with a default theme, just to double-check to rule out your customizations as a factor?

The main “Sites” browse you showed a screenshot of, that uses the same ordering system that the list of sites block should use, and it’s clearly able to properly alphabetize the results. I can’t replicate your issues with ordering or with the block not obeying the maximum number.

One more note: “Template to display” isn’t part of the Omeka S standard “list of sites” block. Does this come from a module?

Now im truly lost for words:

in another site the same theme works correctly :thinking: :upside_down_face: :melting_face:

im confused because the other site is practically the same as this one

Okay it stops working the moment i say Exclude sites: Current site.

That has to be this way because this site is like a HUB for other sites so it would be confusing if the hub leads you to the hub

And the tamplate display is a part of the Block Plus module, eventhough it seems useful i didnt really touch it that much.

Just to check, maybe see if things work with Block Plus disabled.

if i disable the Block Plus the options are diferent:

And it works properly, i guess the module replaces this option and it doesnt work.

Thanks for the help i’ll ask the developer of the module then, sorry for the inconveniences.