Link to my files are being redirected to "example.com"

Hi All! New Omeka user here.

When I installed this a few weeks ago everything was working fine. I have no custom code added, and just two plugins (Stats & AvantCommon). I have deactivated both and the error still persists. Also, this seemed to start happening overnight. When I click on a file to view the photo, it redirects to the correct folder structure and filename, but it says “example.com” instead of well, my domain! It’s super odd and I don’t know where to look, I check all the settings (I think) and search all the core files. Nothing.

Any thoughts here? Here is an example item with the issue: https://archives.abandonedatlas.com/items/show/8

Thank you in advance!

Hi.
If I’m not wrong, in order to use Stats plugin you have to change something in the .htaccess file. I would check there…

Thank you for that response, I have added the code for the Stats plugin, but as mentioned above, I don’t believe this problem has anything to do with stats. I have deactivated both plugins and the photos are still being redirected to “example.com

I mean MAYBE Stats added code somewhere or something, but this is mind bending. I can’t seem to find anything on where a code like that may exist.

I appreciate your input!

The redirect is not only to example.com but also changes the link to add “download” to the URL.

My suspicion would be that this is something being done by an Apache configuration, either an .htaccess file or something in the main Apache configuration. And I see that “Stats” suggests some Apache rules for redirecting access to files using .htaccess configuration (as @DanieleB mentions also), so that’s probably where your problem is coming from. Because this code is added to the .htaccess file, the problem will persist even with Stats uninstalled or disabled.

Note that in the example given in the Stats plugin readme file, the intent is for you to replace example.com with your own URL, and not doing that is really the source of your issue. Of course you could remove those rules entirely instead to just not do the redirect (and you would want to remove them entirely if you’re just not going to use Stats; that configuration will only work, even with the correct URL, with Stats enabled).

Exactly my point, John :slight_smile:

I’m really not sure how I missed this in the .htaccess file. That was it and I feel embarrassed, thank you for your help!