ItemCopy module seems not to work properly

Hello,

I installed the ItemCopy module in Omeka S so as to duplicate items easily. However, nothing happens while selecting the relevant items and clicking on the “+” button next to them.

Any idea how this could be solved?

Many thanks,

Bastien Rueff

Hello,

Did you do the following manipulation, as mentioned in the project README.md?

A few parameters need to be customized directly in the asset/item-copy.js file (starting lines of the file)

  • The key_identity and key_credential parameters : to perform a GET operation on a non-public resource or/and a POST operation to create a new resource, the API requests must be authentified with key_identity and key_credantial parameters. These 2 parameters are given for admin user by activating an API Key in the API keys tab of their user edit page.

If so, there also seems to be a issue with recent versions of Omeka S.

Interesting, when I needed item duplication functionality I didn’t find the ItemCopy module, so I ported the ItemDuplicator (eicas/Omeka-S-module-ItemDuplicator - Omeka-S-module-ItemDuplicator - Codeberg.org).

I only converted the bare minimum to support our use case, though, so I didn’t promote it yet.

I added a link to GitHub - azur-scd/ItemCopy: Module Omeka-S pour dupliquer des contenus dans le dashboard to the README of my ItemDuplicator port for discoverability.

Hi everyone,

Thank you for the answers!

After following manipulation indicated in the README.md, it finally worked! But I needed assistance to do that, as it requires a few informatic skills.

Interesting to learn about ItemDuplicator. Does it copy images along with items?

I’m afraid it does not (yet :slight_smile: )

I think I’ll be fine with the ItemCopy. Thanks anyway and good continuation!

1 Like