Issues with Manual Update to Omeka S 4.0

I am working with a faculty colleague who has an Omeka S site that they would like to update to 4.0, in order to use some of the newer features. Since 4.0 is not yet available in Installatron through our hosting provider Reclaim Hosting, we have tried a manual update process using the instructions in the Omeka S manual but we are getting a 500 internal server error each time: we first tried to update the existing Omeka S site, and then fresh Omeka S installs in case there was some kind of issue with the existing site, and we are getting the same error each time. Does anyone have any suggestions for troubleshooting or for getting this working? Thank you very much for any thoughts you might have to share!

Sometimes when installing/updating from a zip file on Reclaim, the directory and file permissions get out of whack.

Run the following from the command line and you should be good to go (Don’t forget to adjust the permissions for your files directory):

find ~/public_html -type d -exec chmod 755 {} \; && find ~/public_html -type f -exec chmod 644 {} \;
1 Like

This worked – thank you so much for your help!!!

1 Like