Issue using CSV Import+ to update items in collections

We are trying to update items in an already existing collection using CSV Import+, but it keeps creating a new collection called “[Untitled].” Even when we set Default Collection to the desired collection in the first options screen, CSV Import+ creates a new untitled collection and removes the items from their current collections.

Has anyone experienced this issue before / have any ideas for how to fix it?


Could you give me the version you use (should be the last) and the two first lines of your csv?

We’re using CSV Import+ Version 2.3.3.
Here are the CSVs we’ve been testing with (the second spreadsheet just adds some tags to the second item):

Spreadsheet 1:
Dublin Core:Identifier,Dublin Core:Title,Dublin Core:Subject,Dublin Core:Description,Tags

Spreadsheet 2:
Dublin Core:Identifier,Dublin Core:Title,Dublin Core:Subject,Dublin Core:Description,Tags
test2,test2,subject2,description2,“tag1, tag2, tag3”

In my case, it works. So two issues are possible.

Here, the first time I tried the spreadsheets above, the update failed because the " was not a standard quote, but modified into an non-ascii character when I copied-pasted it.

The second possible issue is related to config of the import. So check your delimiter, your enclosure, and the identifier. The main point of CSV Import plus is that it uses an identifier to determine which item to update, and it is a common issue. So uou have to set the identifier field to “Dublin Core:Identifier”.

Thanks for the input!

We found that the import works correctly if we add a column in the CSV file that specifies a collection identifier. That should be a usable workaround for us!

In case you wanted to investigate further, the import still doesn’t seem to work if we don’t specify a collection identifier in the CSV file (i.e. if we just use the “Collection” field under “Default values” in import step 1). These are the steps we’ve been taking to try the import:

  1. Create a new collection titled “Test Collection” with identifier “Test Collection”
  2. Import Spreadsheet 1 (from the earlier post), setting default value for collection to “Test Collection” (this step seems to work; all the items get added to “Test Collection”).
  3. Update the items by importing Spreadsheet 1 again, once again setting default value for collection to “Test Collection.” In this step, Import+ updates the items, but puts them in an untitled collection (and removes them from “Test Collection”). We’re not sure why this happens.

Thanks again for your help!

1 Like

@changt Does your import imported tags also? Or just previous data?

@Daniel_KM: I’m running into the same issue as @changt. The fields are being properly updated for each item, but the items themselves are being moved to a new [Untitled] collection, rather than remaining in the collection I’m selecting in the Default Values > Collection field. Perhaps I’m misunderstanding the functionality of that field?

I’ve had to manually move all the updated items from the newly-created, untitled collection back into the existing (now empty) collection. I must be missing something.

Thanks much!

This is probably a bug to fix.

This topic was automatically closed after 250 days. New replies are no longer allowed.