Interface and Dublin Core Language Change

Hi, I am new to Omeka. We are working with a new installation of Omeka Classic on our servers, it is running well. I want to display the public pages in German, including the names of the DCMI fields. I have changed the locale according to the guide and the respective de_DE.mo file is available in the correct directory. It didn’t work. How can I activate the locale change - or in other words when does Omeka read the config.ini file/how can I force it to read it?
Thanks, any help is appreciated!

The application/config/config.ini file is the only place that setting is read from, so if you’ve set it there, you should be good.

One thing that could be easy to miss: is there a semicolon at the front of the lang line? Semicolons are comments in an INI file, so if there’s a semicolon there, you need to remove it or the line will just be ignored.

Thanks for the quick response!

There is no semicolon in front of that line in /application/config/config.ini. The whole section reads:

;;;;;;;;;;;;;;;;
; Localization ;
;;;;;;;;;;;;;;;;

; locale.name
; The locale identifier used for translating and displaying Omeka.
; default: none
;
; The locale controls what language Omeka will be displayed in, and
; also how dates and other locale-sensitive data will be displayed.
;
; The locale identifier should be a valid ISO 639 language code,
; and optionally a valid ISO 3166-1 locale code.
; (Examples: "es" for Spanish, "en_US" for US English.)
;
; To enable translations, the identifier must also have a
; corresponding .mo file in the application/languages directory.

locale.name = "de_DE"

Should I also uncomment the first and third line?
The corresponding de_DE.mo is present under /application/languages

No, simply that line should be enough.

And you’re seeing no effect at all?

Unfortunately no difference at all. Apart from the content we entered everything is still in English. Here’s a screenshot of the result (I cut out the image):

OK. And to double-check, the same is true on the admin side?

The only other immediate idea I have is that maybe you have a plugin that’s interfering with that setting. Do you have any locale-related plugins installed? Otherwise then we’re looking at things like checking if the application/config/config.ini file is even being read, if there’s more than one Omeka installation on the server and you’re possibly editing the config file of the wrong one, things like that.

A colleague had indeed installed but never used the locale-plugin and I did not know that it overwrites the config-file. Removing it resolved the issue.

Many thanks, @jflatnes!