Installing Advanced Search and Removing Advanced Search Plus

Hello,

I am working with Omeka v3.02 and I was looking to get the Advanced Search Module set up (3.3.6.3). However the first time I put it up on the module folders, our platform became irresponsive - 500 Error and I couldn’t even login. I removed the module folder and it was working again. I think the cause might be that I had an active Advanced Search Plus Module (version 3.3.5.3) working on our system (on my dev site on my local machine the Advanced Search Plus was not installed). I noticed that the Advanced Search Plus is now replaced with Advanced Search and on my dev system with ASP deactivated and installing AS seems to have done this process.

So while I would like to confirm that this was probably the cause of the system going down as I would like to move to the Advanced Search Module. I realize I would probably need to do this in this order:

  1. Deactivate Advanced Search Plus
  2. Copy over Advanced Search into Module Folder
  3. Install Advance Search (if site does not crash)
  4. Activate Advance Search

However currently on the system I have many search strings which I think use the Advanced Search Plus functionality, and I just wanted to check that my query strings will not have to be redone, for example:

fulltext_search=&property%5B0%5D%5Bjoiner%5D=and&property%5B0%5D%5Bproperty%5D=450&property%5B0%5D%5Btype%5D=eq&property%5B0%5D%5Btext%5D=A&resource_class_id%5B0%5D=&resource_template_id%5B0%5D=&item_set_id%5B0%5D=1454&site_id=&owner_id=&datetime%5B0%5D%5Bjoiner%5D=and&datetime%5B0%5D%5Bfield%5D=created&datetime%5B0%5D%5Btype%5D=gte&datetime%5B0%5D%5Bvalue%5D=&is_public=&has_media=&has_original=&has_thumbnails=&has_tags=0&numeric%5Bts%5D%5Bgt%5D%5Bpid%5D=&numeric%5Bts%5D%5Bgt%5D%5Bval%5D=&numeric%5Bts%5D%5Blt%5D%5Bpid%5D=&numeric%5Bts%5D%5Blt%5D%5Bval%5D=&numeric%5Bdur%5D%5Bgt%5D%5Bpid%5D=&numeric%5Bdur%5D%5Bgt%5D%5Bval%5D=&numeric%5Bdur%5D%5Blt%5D%5Bpid%5D=&numeric%5Bdur%5D%5Blt%5D%5Bval%5D=&numeric%5Bivl%5D%5Bpid%5D=&numeric%5Bivl%5D%5Bval%5D=&numeric%5Bint%5D%5Bgt%5D%5Bpid%5D=&numeric%5Bint%5D%5Bgt%5D%5Bval%5D=&numeric%5Bint%5D%5Blt%5D%5Bpid%5D=&numeric%5Bint%5D%5Blt%5D%5Bval%5D=&year=&month=&day=&hour=&minute=&second=&offset=&years=&months=&days=&hours=&minutes=&seconds=&integer=&submit=Search&page=1&sort_by=schema:familyName&sort_order=asc

I can see that the moment i deactivated ASP (without having Advanced Search set up) those queries did not give me any results on the webpages. I am hoping that Advanced Search will just pick them up, am I right to assume that?

Thank you very much,

I am including the Omeka S Config is below:

Omeka S
Version 3.0.2
PHP
Version 7.2.34-23+ubuntu18.04.1+deb.sury.org+1
SAPI apache2handler
Memory Limit 256M
POST Size Limit 256M
File Upload Limit 1024M
Garbage Collection Yes
Extensions apache2handler, bz2, calendar, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gettext, hash, iconv, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, Phar, posix, readline, Reflection, session, shmop, SimpleXML, sockets, sodium, SPL, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, Zend OPcache, zip, zlib
Disabled Functions , pcntl_alarm, pcntl_async_signals, pcntl_exec, pcntl_fork, pcntl_getpriority, pcntl_get_last_error, pcntl_setpriority, pcntl_signal, pcntl_signal_dispatch, pcntl_signal_get_handler, pcntl_sigprocmask, pcntl_sigtimedwait, pcntl_sigwaitinfo, pcntl_strerror, pcntl_wait, pcntl_waitpid, pcntl_wexitstatus, pcntl_wifcontinued, pcntl_wifexited, pcntl_wifsignaled, pcntl_wifstopped, pcntl_wstopsig, pcntl_wtermsig
MySQL
Server Version 5.7.35-0ubuntu0.18.04.1
Client Version mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
Mode ONLY_FULL_GROUP_BY, STRICT_TRANS_TABLES, NO_ZERO_IN_DATE, NO_ZERO_DATE, ERROR_FOR_DIVISION_BY_ZERO, NO_AUTO_CREATE_USER, NO_ENGINE_SUBSTITUTION
OS
Version Linux 5.4.0-81-generic x86_64

modules

Module State
Advanced Resource Template version 3.3.4.8 Inactive
Advanced Search Plus version 3.3.5.3 Active
Alt Text version 1.2.1 Active
Analytics Snippet version 3.3.3.1 Active
Annotate version 3.3.3.6-beta-3 Active
Blocks Disposition version 3.3.2.2 Active
Bulk Edit version 3.3.12.4 Active
Collecting version 1.6.0 Active
CSSEditor version 1.3.0 Active
CSV Import version 2.2.1 Active
Custom Ontology version 3.3.5.1 Active
Custom Vocab version 1.3.1 Active
DataScribe version 1.0.0-beta Active
Dspace Connector version 1.2.0 Inactive
EasyInstall version 3.2.5 not in filesystem
EU Cookie Bar version 3.3.4.3 Active
Export version 1.5.0 Active
Extract Ocr version 3.3.2.1 Not Installed
Extract Text version 1.2.0 Active
Faceted Browse version 1.0.0 Wrong version
Faceted Search version 0.1.0 Inactive
File Sideload version 1.4.0 Active
Folksonomy version 3.3.10.2 Active
Footnotes version 3.3.0.1-3.4.1 Active
Generic module version 3.3.28 Active
Google Analytics version 1.1.2 Active
Group version 3.3.4.1 Active
Hide Properties version 1.3.0 Active
IIIF Server version 3.6.3.2 Inactive
Image Server version 3.6.5.3 Not Installed
Internationalisation version 3.3.10.0 Not Installed
Item Carousel Block version 0.1.0 Active
Item Sets Tree version 0.3.0 Active
ItemCopy version 1.0.1 Inactive
Lockout version 3.3.4 Inactive
Log version 3.3.12.6 Active
Mapping version 1.4.0 Active
Meta Tags version 3.3.0.4 Active
Metadata Browse version 1.4.0 Active
Mirador Viewer version 3.1.7.2 Wrong version
Next version 3.3.39.2 Active
Numeric Data Types version 1.5.1 Active
OAI-PMH Repository version 3.3.5.3 Inactive
OaiPmhHarvester version 3.0.5 not in filesystem
PDF Embed version 1.2.0 Active
RdfDatatype version 3.0.4 not in filesystem
Reciprocal version 3.0.0 Wrong version
Reference version 3.4.30.3 Active
RestrictedSites version 2.0 Active
Rights Statements version 1.2.0 Active
Search version 0.9.0 Active
Sharing version 1.2.0 Active
Simple Carousel version 1.3.0 Active
SiteSlugAsSubdomain version 1.0.0 Inactive
Timeline version 3.4.14.3 Active
unAPI version 1.2.0 Not Installed
Universal Viewer version 3.6.4.4 Active
URI Dereferencer version 1.1.0 Inactive
UserNames version 1.0 Not Installed
Value Suggest version 1.8.0 Active
Value Suggest: Any version 3.3.0.4 Active
Wikidata version 1.3.0 Inactive

On a further exploration I am wondering if the Search module is the problem. My dev site had it active, and when i tried to install AdvanceSearch there was a warning that flashed on the modules page to uninstall it first. I guess on my main site it doesn’t even get to that point.

Search version 0.9.0 by BibLibre Add search capabilities to Omeka S

It might be that I need to uninstall Search first, before trying to upload the AdvancedSearch module into the modules folder?

So i have done some more of the clean up of the modules and found that in the root of my modules folders there is a composer.phar file and i am not sure it might be causing some issues. I can even see it online https://ibali.uct.ac.za/modules/composer.phar

I also noticed that I had a an out of date version of RDF datatypes and have now installed and upgraded it to the DataTypeRDF.

I was going to keep trying to copy over Advanced Search onto my server to see what happens, and keep trying to debug it by switching off certain modules. But I did want to check that by copying it over onto the server, I won’t be damaging what is on the omeka system and database?

Thanks for your help.

So I did a thorough clean up of my modules and not only uninstalled but also removed them from the server, and the the installation of the module and the upgrade worked. Not quite sure what the offending module was.

1 Like