Install Not Found


#1

I know my directory is fine, as I have an omeka classic install there. I know my db.ini is correct because I get different errors when I tried to make it incorrect to troubleshoot. I can’t get omeka s to install. I type in the address bar localhost/omekas and am told it can’t find install, so I type in localhost/omekas/index.php, and I get a blue styled box saying not found. I turned on the error logging as per the instructions but cannot find where to look for an erro log - so two questions - where is the error log, and why am I getting this page


#2

What happens if you go to omekas/admin or omekas/install?


#3

nothing - neither of those directories exist in OmekaS as they did in classic. At least not before install is completed. I can’t get that far. The instructions say to type in omekas and by all indication I’m supposed to be able to start the install process


#4

I should note I’m on a MAc OS server, I set it up myself from apache to mysql to php etc- I’m running the latest of everything- installed high sierra so my php is v7. I’ve had 2 years of experience maintaining classic omeka on a similar server, but it’s on yosemite and server v 4 php v 5…so I need to upgrade to keep up with technology. But as I said, omeka classic works fine on the same machine so I know my directories and config files are fine


#5

also, it’s my database.ini, I mistakenly referred to it as db.ini above (which was correct for classic)


#6

Sounds like what you’d get with a missing .htaccess file.


#7

my .htaccess file is there- I didn’t change what came with the download. and my httpd.conf for apache allows overrides - here’s the .htaccess, it’s in the omekas directory - the fact that I’m getting the styled white box with blue background tells me omekas is involved…

SetEnv APPLICATION_ENV "development"

RewriteEngine On
# The following rule tells Apache that if the requested filename
# exists, simply serve it.
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [L]

# Strip any trailing slashes from incoming requests
RewriteCond %{REQUEST_URI} ^(.+)/+$
RewriteRule .* %1 [R=307,L]

# The following rewrites all other queries to index.php. The 
# condition ensures that if you are using Apache aliases to do
# mass virtual hosting, the base path will be prepended to 
# allow proper resolution of the index.php file; it will work
# in non-aliased environments as well, providing a safe, one-size 
# fits all solution.
RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
RewriteRule ^(.*) - [E=BASE:%1]
RewriteRule ^(.*)$ %{ENV:BASE}/index.php [L]

# Block access to all .ini files.
<FilesMatch "\.ini$">
    <IfModule mod_authz_core.c>
        Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
        Order Allow,Deny
        Deny from all
    </IfModule>
</FilesMatch>

#8

I note the .htaccess file for the classic version doesn’t have all this - but I also wonder about the part that blocks access to ini files…


#9

So, the “blue box” error you’re getting when you go to omekas/index.php isn’t interesting: that’s an error on any Omeka S install. Omeka S URLs as a rule don’t have the PHP filename on them.

It’s the error you’re getting when you try to go to just omekas/ that’s more important/useful.


#10

okay, when I type localhost/omekas (which is what I named the directory). the browser changes it to http://localhost/omekas/install

and the message says NotFound
The requested URL /omekas/install was not found on this server.36 PM


#11

so then I change it to http://localhost/omekas/index.php to get the error in my original post


#12

The white screen error you’re getting on omekas/install is almost always caused by an .htaccess/mod_rewrite issue.

If you just put the word test at the top of the .htaccess file on its own line, does anything change?


#13

no, no change with test at the top.


#14

https://art-090313a/omekas/

you can see it yourself - I don’t have a certificate so you might have to add an exception, I only expected to verify omekas would work and then reimage my actual server, I didn’t anticipate a problem.


#15

The reason for that last edit I asked you to try was that it should cause a change: in this case it should switch every page to showing an Internal Server Error, because “test” is not valid in a .htaccess file.

If it caused no change at all, that means your server isn’t reading the .htaccess file. Usually this means that it just isn’t there (but you checked that), or that the server isn’t set up to read .htaccess files (that’s AllowOverride which you also said you checked). It’s possible it could be something like permissions for that file, but it would be rather odd for that to be the only file that wasn’t readable, so that seems unlikely.


#16

ok, I’m going to go back to the original apache httpd.conf file and redo the coolestguidesontheplanet configuration and see how it goes. Thanks! You’ve helped- I didn’t know where to start…but it seems starting at the beginning might be the right move at this point


#17

I just wanted to add that I’m having exactly the same problem. We have several existing Omeka classic installs. I tried installing Omeka_s on our linux server, added the contents of the .htaccess file to the appropriate virtual host configuration file (right below the contents of the .htaccess file for the omeka classic installs), set up the database.ini file, and restarted the web server. When I go to ~/omeka, I’m redirected to ~/omeka/install, which doesn’t exist, resulting in a 404 Error.


#18

OK, this turns out to be a case of administrator error. I had added the contents of .htaccess to the http version of the vhost file, but had forgotten to add it to the SSL version of the file. Since we have all http requests redirected to https, this was the equivalent of a missing .htaccess file, as was suggested. It’s working now.


#19

This is a classic Apache configuration topic. By default, htaccess is disabled in Apache. It has to be enabled to let Omeka recognize incoming requests.

In short, add this line to either httpd.conf or whatever the virtual host configuration file is (maybe it’s already in conf file, just remove comment # sign), at the appropriate spot:
AllowOverride All
Which apache configuration file to add into depends on your server’s setup. Adding into global httpd.conf will make all virtual hosts htaccess enabled. Adding into individual virtual host conf file will enable for that virtual host only. Consult with your sys admin if possible. Be warned that enabling htaccess will slightly impact server performance, but not a big issue on today’s hardwares.

Please refer to this web page for details: http://ask.xmodulo.com/enable-htaccess-apache.html
Or google “enable apache htaccess”.

It’s unnecessary to copy Omeka-S .htaccess and paste into apache’s configuration file.
Actually, it’s a good idea adding a paragraph of this information into installation section of the user manual.


#20

The requested URL /omeka-s/install was not found on this server.

… same issue as the whole thread. Have been a fan of past of previous Omeka releases.
This release does not give me that warm fuzzy feeling.

Apache/2.4.25 (Debian) Server at localhost Port 80
performed git install pull as well as per documentation … no admin folder no install folder.
I can not get this to install to work.
/.d