Install error msg when creating first user


#1

I’m running into several issues trying to install this on Hostgator’s shared Linux server. I believe the first issue was ensuring that PHP 7.1 criteria was met. The next problem seems to be in the collation. Hostgator says this error is due to the way the Omeka-S application is creating the database. Is that even possible? I see it as a server issue, which I cannot resolve because I cannot access the etc/my.cnf settings to force UTF8. I’ve copied the error text that shows after I try to create the first user. Thanks in advance for any suggestions.

  • There were errors during installation.

  • An exception occurred while executing ‘CREATE TABLE fulltext_search ( id int(11) NOT NULL, resource varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL, owner_id int(11) DEFAULT NULL, is_public tinyint(1) NOT NULL, title longtext COLLATE utf8mb4_unicode_ci, text longtext COLLATE utf8mb4_unicode_ci, PRIMARY KEY (id,resource), KEY IDX_AA31FE4A7E3C61F9 (owner_id), FULLTEXT KEY IDX_AA31FE4A2B36786B3B8BA7C7 (title,text), CONSTRAINT FK_AA31FE4A7E3C61F9 FOREIGN KEY (owner_id) REFERENCES user (id) ON DELETE SET NULL ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci’: SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 767 bytes


#2

We’re aware of this issue… it’s possible to work around it on the server side with different MySQL settings (or upgrading the version of MySQL), but we will also make a release that avoids the problem on our end.


#3

So that I might get started before your fix, what specific workarounds do you suggest on a shared-server installation on Hostgator? I’ve not had any success changing the database and retrying the first-user entry… because I always get subsequent errors with pre-existing tables, etc.

Do you have an ETA on the version that fixes this?


#4

Same issue here running PHP 7.3, MySQL 5.6, and using a utf8_bin database. I suppose I can try upgrading MySQL to 5.7 and see if that fixes it.


#5

Upgrading to MySQL 5.7 fixed it!


#6

Yes, the default settings for MySQL 5.7 and up don’t exhibit this issue.

We’ve also released the new version that fixes the issue for users on MySQL 5.6, version 2.0.2, available as usual from omeka.org/s/download


#7

Thank you for the quick response - I was able to create the first user and move forward with the installation.