Import skos vocab in Omeka-S


I just tried to import the skos vocab to describe links between three different concepts ( I need the classes skoas: broader/narrower/broaderTransitive and narrowerTransitive. Here is the page i filled in and the mistake message above:

No class or properties found. Are you sure you used the correct namespace URI ?
I filled in this way :

Vocabulary URI :
Préfix : SKOS
Spacename URI :
Label : SKOS

I am a beginner in Omeka-S , so sorry in advance if is an easy mistake to correct but I cannot find solutions.
Many thanks,

This should work:

Vocabulary URL:
Prefix: skos
Namespace URI:
Label: SKOS

It works !
thanks a lot

Hello everyone,
I managed to import ontology skos but it is incomplete, there are only 18 properties out of 28.
For example, I do not see the following properties: skos: altLabel, skos: prefLabel …
thank you in advance for your help


surprising then I have the 28 properties available. Sorry I cannot help you further.

Hello everyone,
new attempt to import skos vocabulary from the latest Omeka S sandbox:
I reproduce the same error = only 18 properties!
the import parameters is the same of jim post

thank you in advance for your help

Hello everyone,

I encountered this too - only 18 properties (and none of the ones I wanted!).

Here is a workaround:

  • download the SKOS RDF document.
  • remove all the lines that say <rdf:type rdf:resource=""/> and save the file.
  • import the vocabulary from that file.

I was able to import the vocabulary with 28 properties.

It is an old issue #1447. The development version of Omeka fixes it.
I just published a first version of a module Thesaurus, that contains a resource template and a helper to recreate the tree of the skos concepts if needed.