Import Settings Expired

We are trying to import an xml from OHMS into Omeka and are getting the message “Import settings expired. Please try again later”. We use Reclaim Hosting, and the Omeka version is 3.1 and OhmsImport is 2.0.7.

I read through some old Topics with the same title, and those recommended changing browsers. I tried Edge and Chrome and Firefox, and even Safari from a Mac, and still cannot import. A week ago, after trying and failing, I tried one more time with Firefox and it worked! Now it doesn’t.


Is this the correct forum to receive help for our issue? We are currently at a standstill until we can get some help. We have tried four different browsers and none of them work suddenly. Please advise…thanks!

There’s a known problem with the OhmsImport plugin about this “Import settings expired” message.

The OhmsImport plugin instructions, and their guide, recommend that you edit your Omeka database manually to change the “sessions” table. Did you do that when you installed? That step is what’s supposed to avoid this problem.

When I looked into OhmsImport a little after your previous question, I sent suggested fixes both for that problem of warnings on PHP 8 and for this “import settings expired” problem. With that fix applied, editing the database would no longer be required to use the plugin.

Hi. Thanks for the PHP deprecation messages. I fixed that. We’ve been doing Omega and OHMSImport since 2020, and we have about 60 oral histories complete. For some reason it stopped working a couple of weeks ago. I followed all the documentation during installation, and now will go check again.

Thanks for your reply.

Probably your server was updated to use newer PHP recently and that’s why you saw the messages about it more recently. Those would only show if you’re using newer versions of PHP.

If comfortable, you could also try to apply the code change I linked to your own copy: the change is available as a patch or alternatively is only the addition of three lines of code.

The configuration changes were already done. I even changed the ‘data’ configuration value to ‘longblob’ and it still didn’t work.

I’m not really comfortable making the code changes. I assume the patch is on GitHub in the OHMSImport plugin?

So the page I linked to, the second link up there in my earlier comment, that’s the pull request I made to the OhmsImport GitHub. The patch is there, yes.

This is it formatted as a patch file, and here’s the GitHub page for the PR again. The change only updates one file, so another option would be to download the updated file and use that copy to replace the “models/OhmsImport/File.php” file in your current copy of the plugin.

It’s possible, though, that you’re having some other problem… “longblob” would fit a very extensive transcript.

I got this from Doug Boyd, it fixed my problem:

If you using a Reclaim and upgraded Omeka, essentially, you have to repeat the initial steps you took when you optimized your Omeka instance to work with the OHMS Plugins. The upgrade has overwritten the MySQL customization that you did, as well as the background.php path that you placed.p. I recommend going through the steps (outlined in the guide). This should allow the import to function properly again.

If I’m reading you correctly, your “sessions” table got reset basically, so you had to make the same change again, the “mediumblob” or “longblob” change we were talking about, and doing that fixed the problem for you?

Here is a link to the OHMSImport User Guide. Pages 4-7 have the details to change 3 items that fixes the issue.

OHMS-Plugin-Suite_v1-1-1.pdf (

OK, so yes, it was the same problem we’d been talking about throughout the thread, the sessions table size.

That means that the patch I mentioned earlier would have also fixed the problem; the purpose of the patch is that it makes it no longer necessary to make that database change as the OHMS guide currently indicates.