ImageMagick Path is not ok


I just migrate my working Omeka site to another hosting provider ( OVH ) and thumb are not generated when uploaded.

I check the imageMagick path (/usr/bin), and in Omeka it says it is not OK.

So I think I found the issue. Now the weird thing is when I ssh into my instance, and run which convert the result is ‘/usr/bin’

I am also sure that ImageMagik is installed and the version is :

Version: ImageMagick 6.8.9-9 Q16 i586 2017-05-23

Why is Omeka saying that /usr/bin is not the good path???

When the path is right but we still complain about it, that usually means something like PHP’s safe mode or open_basedir is in effect and restricting us from checking the path. Some hosts also simply disable the functions Omeka uses to execute ImageMagick, resulting in an error. It’s probably best to check with your new host to see what’s up and what options you have.

1 Like

after speaking with OVH Support, it seems there is no problem.

PHP Safe mode doesn’t exist anymore in PHP7.
and open_basedir is set to null in php.ini

As OVH has Imagemagik preinstalled in their servers, it seems weird that they could block his use…

still have no clue of this issue…

In old times, OVH changed its params very often, so I created a plugin to manage the changes ( Now, it is useless: see the readme of the plugin.

Yep … I still don’t have a solution. I guess I will rollback my migration and stop using OVH :frowning:

Did you try to update application/config/config.ini with:

fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_Imagick"
background.php.path = "/usr/local/php7.0/bin/php"

and to update the file .ovhconfig at the root of your server with:


yes i also want know coz Am facing the same problem. Hope anyone here can help me too. Thanks in advance. Regards,
miles smith