ImageMagick directory path does not work in Windows MAMP

Apologies for raising an issue that others have already raised a few times, but none of the solutions I’m reading here have worked for me.

I’ve installed Omeka Classic 2.8 using MAMP for Windows 10. I’ve downloaded and installed ImageMagick from https://imagemagick.org and verified that it’s working. If I type where convert and where magick at the Windows command prompt, I get

C:\Program Files\ImageMagick-7.0.11-Q16-HDRI\convert.exe
C:\Program Files\ImageMagick-7.0.11-Q16-HDRI\magick.exe

Similarly, in Git Bash, I get

/c/Program Files/ImageMagick-7.0.11-Q16-HDRI/convert
/c/Program Files/ImageMagick-7.0.11-Q16-HDRI/magick

But neither

C:\Program Files\ImageMagick-7.0.11-Q16-HDRI nor
/c/Program Files/ImageMagick-7.0.11-Q16-HDRI

works in the ImageMagick Directory Path field in Settings. I’ve tried escaping the space in Program Files in various ways without success, as well as enclosing the whole path in quotation marks.

I’m missing something. But what?

Update: I implemented the fix recommended by gsoules in this thread on the same issue, making the change in \application\libraries\Omeka\File\Derivative\Strategy\ExternalImageMagick.php to add the .exe extension to convert. This worked to get Omeka to recognize the ImageMagick directory path.

However, it didn’t work to get Omeka to actually display images. I tried substituting magick.exe for convert.exe but that didn’t work, either.

Finally, I implemented the recommendation from jflatnes to add this line to application/config/config.ini:

fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_GD"

That worked to get images showing up. :tada:

Since Omeka recognizes the directory path for ImageMagick, however, there’s perhaps some adjustment I can make so that it uses ImageMagick for conversions?