ImageMagick check not working

Although there are several topics around with this issue, none of the proposed solutions appear to be working for me.
This is the scenario:

  • Omeka classic 2.7;
  • web site, linux hosting, with ImageMagick installed and properly working (more about this later);

In the Settings->General panel, ImageMagick directory path (IMdp):

  • entering a path different from /usr/bin/ produces an error (‘The ImageMagick directory path does not work.’);
  • entering /usr/bin/ produces no output (exception raised);

Whatever the path, images are not processed.

Tried and run the following script on my web site:

$ret = exec('convert -version');
echo $ret; 

The following result is produced:
“Delegates (built-in): bzlib fontconfig freetype jng jpeg png tiff webp x xml zlib”

It looks like the “executeCommand” function in the ExternalImageMagick.php module fails with an exception.

What can I do to make Omeka aware that ImageMagick actually works fine?
Thanks for your time!

ETA: After delving into Omeka source code, I see the convert command is executed using proc_open() (see ExternalImageMagick.php). Unfortunately, running proc_open() on my web site fails with the following message:
**Warning** : proc_open() has been disabled for security reasons
Is there any alternate way to run the convert command other than using proc_open()?

OK, after spending some time with php syntax here is my best effort at finding a workaround to proc_open():

    public static function executeCommand($cmd, &$status, &$output, &$errors)
        // Must use exec('convert') because our service provider has
        // disabled proc_open() for unspecified security reasons.
        if ($output = exec($cmd)) {
            $errors = '';
            $status = 0;   // set to success
        } else {
            throw new Omeka_File_Derivative_Exception("Failed to execute command: $cmd.");
            $errors = 'exec unsuccessful';
            $status = 1;	// set to fail

Now this works fine with testing ImageMagick, but still I cannot add pictures nor have the fancy thumbnails everyone seems to be able to show near the items. Every time I try to add a picture, I get the same message:

Omeka has encountered an error
To learn how to see more detailed information about this error, see the Omeka Codex page on [retrieving error messages](

Hmm, looks like I’m stuck. Anyone?

I hope no one gets offended if I bump this thread up…

Did you try to follow the instructions linked from the error message? That should give you an actual error message instead of that generic one.

Thank you, John.
Yes, I tried and uncommented SetEnv APPLICATION_ENV development, but nothing changes and the error message still remains the same.