IIIF Media not importing

I am trying to import an IIIF Media from an external server. I have already created the metadata, when I go to the “media” window and I insert the info.json it gives me a general “Omeka S has encountered an error”, but there aren’t any logs in the log file (they appear for other type of errors). I don’t think there’s a problem in my IIIF json, because I have the same issue with this json taken from the Library of Congress:

https://tile.loc.gov/image-services/iiif/service:sgp:sgpbatches:batch_dlc_anacostia_ver01:data:sn84025948:0023728866A:1942081001:0202/info.json

Plus, in my server there is a 200:

Responded to GET /iiif/2/C001467P_Samugheo_MilanoVendemoda_25.tiff/full/full/0/default.jpg with HTTP 200 in 190 msec

I think I am doing something wrong, but I cannot figure out what.

This is using the “IIIF image” media option, right?

What version of Omeka S are you using? Some “encountered an error” pages can not be logged on some older versions.

Anyway, if logging isn’t including the error, you can instead try the “Display” instructions from the manual.

Yes, it is.
I’m using an old Omeka S version: 3.0.1. Would it be better to upgrade it, maybe?

Update: ok, I set the Display as “development”. Now with the Library of Congress IIIF it gives me this message

Directory “/var/www/omeka/omeka-s/omeka-s/files/large” is not writable.

Details:

Omeka\File\Exception\RuntimeException: Directory “/var/www/omeka/omeka-s/omeka-s/files/large” is not writable. in /var/www/omeka/omeka-s/omeka-s/application/src/File/Store/Local.php:105

While with my IIIF it says the same thing

Directory “/var/www/omeka/omeka-s/omeka-s/files/large” is not writable.

Problem is that I have it writable (if I’m not mistaken), with in /files ls -l I have:

drwxr-xr-x 2 root root 4,0K ago 3 14:34 large

That output doesn’t show that folder as writable.

drwxr-xr-x means the folder is writable for the owning user only, and that’s root (that’s what’s indicated by the two dashes where a “w” would otherwise be). The user that your webserver/PHP/Omeka run as is almost certainly not root, so it can’t write there.

So there’s something that needs to be changed about that permission: typically you want to make it share an owner/group with the server user and then just allow that specific permission (the permissions you have now would be OK if the server user owned this folder, for example). There’s also a “scorched earth” option of “777” permissions, meaning read, write, and execute permission for any user on the system, but that’s usually not recommended.

1 Like

Thank you very much! I changed the permission in www-data_root and now it’s working fine. Sorry for the ignorance!