I can't upload files to items

Dear friends, I’m getting started with Omeka, running on web. I can’t upload any files to items,in this case i upload pdf whereas files under 8mb. It shows an error: “Omeka has encountered an error”. i already ceck setting on file validation allow file to be uploaded to Omeka.
how the best solution of this problem

Hard to say without logs. Is there any message in logs/errors.log? If not, can you set the development mode in the file .htaccess at the root of Omeka? Generally, this is related to an issue with the php path or with image magick.

this is my omeka login elib.perpustakaanrsmcicendo.com/admin/index.php
i had been doing instruction in the retrieving error messages link, but the error become more severe
username: admin
pasword : admin777
you can help me check for the error

In http://elib.perpustakaanrsmcicendo.com/admin/index.php/settings/edit-settings, when you click the button “test”, php is not found. Ask your administrator for the path to the command line version of php, that is required for background process, for example the creation of thumbnails.

And change your password now!

Still error, I’ve contacted my administrator, but the administrator can not find detail the problem that I experienced, he gives this link to be informed to the omeka developer http://elib.perpustakaanrsmcicendo.com/cek.php

On that page there are some configuration information that may be needed by omeka developer, or perhaps a server requirements as to what is needed by the script.

There is no information about the php cli command in the php info. The php cli is the command of the php command line interface that you should set in application/config/config.ini. Anyway, you have imagick installed, so you can try to set fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_Imagick" in this config file.

I’ve done that,but still error

Could you enable the messages? Just modify “.htaccess” at the root of your install and uncomment SetEnv APPLICATION_ENV development. You will have the messages of error displayed.

this is uncomment setenv APPLICATION_ENV development

what should i do next?

At line 14, you remove the # to uncomment the line, and you save the file. Then errors will be displayed.