Huge Module Install Problem after

I am having quite the problem with updating modules in Omeka S after updating to 4.04. I think my settings are likely screwed up somewhere, but let me just try to explain.

First, I removed all the modules from the modules folder, and deleted them from the db. I then tried to reinstall Log, and when i do, it says “error loading module,” and when i try to look at the admin window, it throws a blank page. So, I then remove Log.

Second, I thought maybe this had to do with some kind of php issue, but i tried changing php versions, and that didnt do anything either. Im assuming running 8.2 php is good?

I had used EasyAdmin in the past to load theme and modules, and of course that i not working either.

Am I missing something obvious?

I should also say that at the admin window within cpanel it says “Note: There appears to be a problem with the saved database information. Use the above “Advanced” tab to enter correct information.”

when i go to advanced it doesnt say much.

First, I removed all the modules from the modules folder, and deleted them from the db.

When you say you “deleted the from the db,” what did you do? This isn’t a normal part of upgrading: you shouldn’t be deleting anything about the modules from the database.

whoops. i went into phpmyadmin because i read somewhere that if you are getting errors from modules being in the db but not in the file structure you should do that…w

If you delete all the files of your modules, every one that was installed will show a message saying that it’s “in the db but not in the filesystem.” This is expected: it’s telling you that you don’t have the files present for one of your installed modules, which makes sense because you just deleted the files.

The way to proceed from there is just to put the updated module files in place. The Modules screen will then show an option to upgrade the module, and you’re done. If you manually go in the database and delete the entry for the module, then the system won’t know you have it installed, and there will be no way to properly upgrade it.

If you took a backup of the database before upgrading, it might be best to just wipe your current database, restore the backup, and start the upgrade process over. You can do that without having to re-do the steps of updating the core and module files.

Thanks for that.

What seems to be the root of the problem, maybe, is the Log module. I cant install EasyAdmin without it, yet when I install Log it causes errors.

Ive successfully installed the modules that i had deleted…except for Log and EasyAdmin. They keep breaking it.

If you’re just going forward from where you were, I’d hazard a guess that you have to also drop the Log module’s table (it’s just called log) before you try installing it again. It’s not expecting it to already be in the database when it gets installed.

Be aware, this will remove all prior logs that are stored in that table.

1 Like

I will give this a try.

That didnt work. But i will continue to try that line of thinking.

this is from the error log…looks like whatever this is keeps repeating.

[02-Dec-2023 04:02:23 UTC] PHP Warning: require_once(/home/tjfinano/ Failed to open stream: No such file or directory in /home/tjfinano/ on line 49
[02-Dec-2023 04:02:23 UTC] PHP Fatal error: Uncaught Error: Failed opening required ‘/home/tjfinano/’ (include_path=‘.:/opt/cpanel/ea-php82/root/usr/share/pear’) in /home/tjfinano/
Stack trace:
#0 /home/tjfinano/ Log\Module->init(Object(Laminas\ModuleManager\ModuleManager))
#1 /home/tjfinano/ Laminas\ModuleManager\Listener\InitTrigger->__invoke(Object(Laminas\ModuleManager\ModuleEvent))
#2 /home/tjfinano/ Laminas\EventManager\EventManager->triggerListeners(Object(Laminas\ModuleManager\ModuleEvent))
#3 /home/tjfinano/ Laminas\EventManager\EventManager->triggerEvent(Object(Laminas\ModuleManager\ModuleEvent))
#4 /home/tjfinano/ Laminas\ModuleManager\ModuleManager->loadModule(Object(Log\Module))
#5 /home/tjfinano/ Laminas\ModuleManager\ModuleManager->onLoadModules(Object(Laminas\ModuleManager\ModuleEvent))
#6 /home/tjfinano/ Laminas\EventManager\EventManager->triggerListeners(Object(Laminas\ModuleManager\ModuleEvent))
#7 /home/tjfinano/ Laminas\EventManager\EventManager->triggerEvent(Object(Laminas\ModuleManager\ModuleEvent))
#8 /home/tjfinano/ Laminas\ModuleManager\ModuleManager->loadModules()
#9 /home/tjfinano/ Omeka\Mvc\Application::init(Array)
#10 {main}
thrown in /home/tjfinano/ on line 49

See readme: Log contains a dependency. So you should install it either from the package link in the modules list of, in the list of realeases in the right of github. If you use the big github button and download “master”, or if you use git, you have to run this command from the terminal, inside the module Log directory: git install --no-dev.

Thank you very much for that. I have no doubt that’s the issue and apologies for not noticing. You’ve done an incredible job posting modules for Omeka-s. I am extremely grateful.

At some point I may contact you about a project we are proposing with our research computing group at slu. It would basically involve creating a module similar to the one you developed for using repositories. We have been working on an annotation repository at and linking it to omeka-s would be a major advancement of that project.

Thanks again