How to stop display exhibit layouts


I have created a plugin that will create three new exhibit layouts. My question, how to stop showing the default four exhibit layouts comes with Exhibit builder out of the box when I installed it?

So we do not want our creators to use any of the Exhibit builder exhibit layouts, only our custom layouts that I created using the new plugin?

I can go and remove the folder from the Exhibit builder but I do not want to hack the Exhibit builder code for future upgrades.


Your filter that adds the new layouts can also remove the existing ones, or just throw out the existing $layouts array and build a new one.

It works but I received an error on pages that used file-text layout.

Notice: Undefined index: file-text in /plugins/ExhibitBuilder/models/ExhibitLayout.php on line 203

do I have to migrate all previous data from file-text layout to the newer layout?


Yeah, if you want to remove all the “regular” layouts you’re going to want to make sure that nothing’s using them first. The system’s not exactly designed for this use case but it should work fine as long as you remove or transfer any existing data in layouts you’re removing.

I see what you are saying, and thanks for getting back to me.

Is there a way, I can add an option for file-text layout so images can display in center position and able to display the full image. What I need is to add “Center” and “full” to the select box in the “file-text” option block. I can do it by hack the Exhibit builder, but I do not want to do this. I can create a new layout but I have to migrate all exhibits using “file-text” to my new layout. I have a feeling there might be a solution to add to the list value in “File-text” without creating a new layout or hacking the code. Is there a filter or hook where I can change the views for the "file-text " layout in exhibit builder?



How to change the cost FALLBACK_LAYOUT from ‘file-text’ to my new layout?
I do not use file-text anymore. I do not want to hack and change it in the Exhibit Builder plugin.

This topic was automatically closed after 250 days. New replies are no longer allowed.