How to allow double space after periods?

How does one allow double space after periods? Omeka changes all of my double spaces to single spaces. On a side note though, what is the logic behind not allowing double spaces after periods? Double spaces after periods are important for read flow and for quickly sighting one’s place. Who would go through the trouble of disabling such a thing? What would be the reason for originally doing such a thing from a programming perspective?

Omeka does not remove double spaces after periods. If you edit the resource, you’ll notice that double spaces are preserved. What you’re seeing is intrinsic to HTML. Browsers will automatically compress multiple whitespace characters into a single one. If you want to preserve whitespace when rendering your text as HTML, you could use the white-space: pre; style.

Ok, where do I enter that?

It depends on where you want to apply the style change. If you want to apply them to the public theme, open themes/<your-theme>/asset/css/style.css and apply the style change there. If you want to apply them to the admin theme, open application/asset/css/style.css and apply the style change there. Make sure you only apply the change to the element(s) that need it. Here’s some basic info about CSS.

Would there be any way that y’all could make this a setting that can be enabled via gui? Because I had a major headache trying to find a CMS that could do this and I was stoked about Omeka. I like it more than WP, Drupal and Joomla…if y’all would cater to writers and make it simple like that I guarantee you that you would have a large drove of new users because not being able to have something simple like that is very annoying.

Perhaps someone can build a module or theme that caters specifically to writers. Thanks for your suggestion.

If you don’t have access to your theme files, you can use the module css editor and copy/paste the code above.