Homepage (index.php) not available - "Page isn't redirecting properly"

Hi all,

Having some trouble with a recently installed Omeka page. Was working fine for a few days, but now the homepage isn’t reachable - Firefox gives error “Page isn’t redirecting properly.” All other pages (/admin and specific content pages) work fine. After doing some research on these forums I decided to add

DirectoryIndex index.php

to our .htaccess file, but it still doesn’t work. I should mention that even if I specifically append /index.php to the website name, it still doesn’t load the homepage (same error), which makes me think it’s not an .htaccess issue, but I’m open to suggestions.

The text of .htaccess is:

Omeka .htaccess: Apache configuration file

This file is required for Omeka to function correctly.


Error Reporting


Uncomment the SetEnv line below to turn on detailed on-screen error


Note: This should only be enabled for development or debugging. Keep this

line commented for production sites.

SetEnv APPLICATION_ENV development


Rewrite Rules


RewriteEngine on

If you know mod_rewrite is enabled, but you are still getting mod_rewrite

errors, uncomment the line below and replace “/” with your base directory.

RewriteBase /

Allow direct access to files (except PHP files)

RewriteCond %{REQUEST_FILENAME} -f
RewriteRule !.(php[0-9]?|phtml|phps)$ - [C]
RewriteRule .* - [L]

RewriteRule ^install/.$ install/install.php [L]
RewriteRule ^admin/.
$ admin/index.php [L]
RewriteRule .* index.php


Access Control


Block access to all .ini files.

<FilesMatch “.ini$”>

Require all denied

<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all




Uncomment the lines below in order to enable caching of some files

(after a finished site has gone live)

<FilesMatch “.(js|ico|gif|jpg|png|css)$”>

ExpiresActive on

ExpiresDefault “access plus 10 day”


PHP Settings


php_flag register_globals off php_flag magic_quotes_gpc off

And the text of index.php is:

<?php /** * Omeka * * @copyright Copyright 2007-2012 Roy Rosenzweig Center for History and New Media * @license http://www.gnu.org/licenses/gpl-3.0.txt GNU GPLv3 * @package Omeka */ // Bootstrap the application. require_once 'bootstrap.php'; // Configure, initialize, and run the application. $application = new Omeka_Application(APPLICATION_ENV); $application->getBootstrap()->setOptions(array( 'resources' => array( 'theme' => array( 'basePath' => THEME_DIR, 'webBasePath' => WEB_THEME ) ) )); $application->initialize()->run();

I’d appreciate any help.

Thanks! -A

Am I reading you right that only the homepage doesn’t work but all other pages do? Including the entire admin section?

I can say for sure you don’t need the DirectoryIndex line you added, so you should probably just take it out.

One thing to check, have you tried to customize your homepage from the Navigation section of the admin? A bad setting there would explain an issue that only cropped up after a little while.

Hi jflatnes, thanks for responding! Yes, the only page that is not working is the homepage, I believe I have total access to the Dashboard and other settings. That said, I’m not seeing any options for Navigation settings. Could you be more specific on where I should be looking? We’ve had some students working on the site, so I’m not 100% sure what has been changed and what hasn’t.

And to confirm, yes, I did revert to the previous .htaccess file without the DirectoryIndex line after it didn’t help.

Thanks again for the assistance,

What are your plugins?

Hi wingluke - Navigation is a option under the Appearance settings - one of the ones across the top rather than the side.

Thank you so much! Switching the homepage setting from “Home” to “Default” fixed the issue.

Just so I can be sure I understand the cause of this problem (and in case we want to change the homepage in the future), I’m guessing that the homepage setting was pointing towards one URL and some other setting somewhere was pointing to another? And that would cause the “Too many redirects” error? Any idea where the conflicting data is?

The homepage setting is there to force a redirect when you go to the homepage, effectively changing the homepage to some other Omeka page.

It sounds like someone on your installation created a “Home” link in the navigation (there isn’t normally one by default) and set that to the homepage, essentially telling Omeka to redirect from the homepage to… the homepage. This is a pretty straightforward way to create a redirect loop, which is what the browser was complaining about.

Got it. Thanks again to the Omeka Team for the prompt and informative replies!