Highlighted collection doesn't display the information

Hello,

I have difficulty displaying collection (i added one and here it is)


I used the highlighted

so it should display it but it only displays this
image
For my index page , i manually input HTML to make it work
image
I also looked for javascript file to see if i needed to add anything or do something so the button "Highlighted " will function and i wont need manually add informtion in simple page plugin.Briefly , I simply want my page to be dynamic by this button in collection plugin

Have you tried with “Audience”?

Same problem sadly …

Is that a specific plugin you’re dealing with? I’ve never seen the checkbox “Audience” or a “To delete” button before in Omeka Classic.

No , it is the “collection” plugin, maybe the naming is weird because i translated it from french to english

Sorry, but I am not familiar with such a plugin. I know Collection Tree and Multicollections plugins, but not a Collection one. Where did you find it, could you provide a link? And what is its purpose, given that Omeka Classic already works with collections? I’m a bit puzzled here…

Hey sorry for being cofusing. Here is the link : Collections - Omeka Classic User Manual
The purpose it is to gather different content together . So it will end up looking like that :

Thanks.

Now that we know we’re talking about a normal Collection, if you checked both “Audience” (=Public) and “Highlighted” (=Featured) then the Collections should be displayed in the home page under “Highlited collection”.

Can you confirm they’re both checked (in your first picture, only “Highlighted” was checked), and the page saved? And could you also provide with a link to your site, if it’s public?

So here is the site : Accueil · Fusion Jeunesse - Bibliothèque
Here is now marked them both :
image
I also want to mention that i added the page "welcome " to be my homepage and its URL is …/accueil

Ok, accepting that the information has been correctly recorded in the db, I wonder whether the code in the ‘featured-collection’ DIV is correct, then. Could you check that and maybe show it here (in the fourth picture the div was collapsed)?

Ok so here is the webiste as it is


This is the simple page’s code :

Maybe because i copied the h2 and p element, which I was not supposed to?

Yulia, now I understand what has happened: you have just created a static Simple Page that will always show what you’ve coded, i.e. “Aucune collection n’est mise en avant”. That page will never update with actual content, because it’s a static page.

If you looked at the index page of themes that are showing featured collections, you’d see the code is different, and includes a dynamic part that’s retrieving the information from the db and displays it.

In order to do something similar in a Simple Page, you need to use shortcodes. Documentation page, with examples, is here: Shortcodes - Omeka Classic User Manual

1 Like

thank you a lot ! it worked perfectly