Help with images

Hi all,

I’m not too sure what’s going wrong or how to fix this issue I’m having. I have Omeka-S running on a server hosted by iPage. Everything is going smoothly, no issues however certain images won’t show up at all.

For example, I can get a PGN file to show up here:

However uploading another PNG file it just does this:

There’s no difference in how I uploaded them or set them up. I’ve tried different files (and types). Tif, JPG… etc, only that one PNG file seemed to work. However, I uploaded a tif file, then went into thumbnails and was able to upload the same file as it’s own thumbnail, the image showed up but it still doesn’t show up on the page. I tried saving the not working files as different file types but it still isn’t working.

Image links can be clicked and viewed. I even tried importing them from another website via URL and that still did the same thing. The only image that work is the random PNG!

The issue you’re having is that Omeka is unable to generate thumbnails for those images. You might want to check with your host about their support for ImageMagick; you could also turn on error logging (the second bullet point on that page), which should show an error message from ImageMagick if there is one.

Servers can have quite a bit of control over what’s allowed for ImageMagick to work on; it’s possible that your server has a fairly harsh restriction on the allowed pixel size or file size, for example.

Thank you for the reply! I had reached out to iPage earlier and they said ImageMagick is installed and working.

However, I never thought to think about the image size being the problem! I’m going to try another smaller file and see if that works.

Thanks again!