Geolocation3.0 Map and located items not visible

Upgraded to Geolocation 3.0 on an installation of 2.6.4 as well as 2.2. Both were running 2.2.3 of Geolocation fine. Deactivated and removed previous versions and then uploaded and extracted 3.0. From admin/plugins, clicked the upgrade button presented and then clicked save to activate. Plugin activates, but the map itself will not display in either admin or user views. Tried changing map type between Stamen, OSM and Carta but no luck. Changed a few parameters to see if that would do anything, but still no luck.
Screenshot attached of the result. 3 Items selected but blank where the map is. Is there something missing in my setup. I reinstalled the earlier version of geolocation on 2.2 and happy to see map reappear.
There is no custom styling applied. Instances of Omeka are on different servers.
Code for map seems to be appearing:

Find An Item on the Map


What happens if you deactivate Neatline?

Deactivated Neatline 2.6.1 +timeline and text. Doesn’t seem to have any effect. The map still missing.

The map was not appearing in either user or admin view when viewed on OSX Safari. However, the map was visible when using Chrome on OSX. After verifying that map appeared through Chrome, went back to Safari and deactivated ‘warn when visiting fraudulent websites’ in the Safari security setting and the map suddenly appeared.
Thanks @mebrett for the help.

1 Like

Hmmm, that’s odd…

If anything, Geolocation 3.0 loads less from other sites/domains than the old Geolocation does, so it’s strange that the setting you mention would have an effect.

Is it possible the issue was actually just a caching problem? That would also explain it working in Chrome but not Safari, if you’d generally only used Safari before. Perhaps switching that option also had the effect of clearing the cache. Does it “re-break” if you turn the setting back on?

Alas, do expect that it is merely caching when changing between the old and new versions of the plug-in.
Works fine now with that switch turned back on.
When I went back to Chrome after having the older version of Geolocation enabled and then upgraded to v3.0 and it wouldn’t work in Chrome but would in Safari. Yes, the most basic clearing the cache (chagrinned) solved it fine.
Apologies for all the bother. My own ineptitude,

I have the same problem with Safari as originally reported by shawnday on June 20.
Responding to mebrett on June 20: I do not have neatline installed and never did.
Responding to shawnday on June 20: The maps display properly when using Firefox on OSX and on Fedora 28 (Linux). I do not have Chrome, so I cannot judge its performance. I did go back to Safari and deactivated ‘warn when visiting fraudulent websites’, however the map did not appear. I reactivated ‘warn when visiting’ which had no effect.
Responding to jflatnes: I cleared the Safari cache. Maps still do not display in Safari.
I expect that the problems I experience may relate to my updated Mac operating system (Mojave). I am also running the latest Safari (Version 12.0).
Performance on Firefox seems fine at all times under both Mac Mojave and Fedora 28. I am running Firefox 62.0.3 which is the latest version.
Thanks in advance for your help.

@elewis - what versions of Omeka and Geolocation are you running?

Omeka 2.6.1. Geolocation Version 3.0

Does changing which base map you’re using make a difference? And do you have any extensions or ad blockers active on Safari which are not enabled in Firefox?

(I’m on El Capitan and Safari 11.2 and the maps load fine)

This topic was automatically closed after 250 days. New replies are no longer allowed.