Geolocation public browse not loading any items

Setting up a new site and using Geolocation.
Geolocation is working every where except for the geolocation/views/public/map/browse.php page.
No matter how many items are mapped, currently just 1, when accessed the browse map page will flash quickly and then display the title only (blank page except for the title) of the first item to be mapped.

You can see it here: http://wargame-scenarios.com/geolocation/map/browse

If I go into the admin browse page it loads correctly, same with item pages.

Thanks, any help would be appreciated.

Notes: Using Omeka version 2.7.1 and Geolocation 3.2

I’m not 100% certain it’s related, but there is something odd happening on your other pages with a “linkify” script appearing many times in the output, and something like that seems like it could cause some strange effects like what you’re seeing with Geolocation.

I believe that would be the ClickableLinksPlus plugin, so you could try deactivating that to see if it resolves the problem. (If it doesn’t, try deactivating other plugins to rule out an incompatibility between them).

It was the ClickableLInksPlus plugin.
I disabled it and Geolocation worked.
But, I thought that it had worked earlier with all my installed plugins activated.
So, I worked on the Config for ClickableLInksPlus.
With no elements selected in the config, ClickableLInksPlus did not cause Geolocation to fail.
Basically, after trying each element individually to see when the error occurs, it is the “Title” element when activated in the ClickableLInksPlus config that causes the Geolocation module to fail in the Map view.
As long as Title is not selected in ClickableLInksPlus plugin it does not cause any issues with the Geolocation plugin.

1 Like