Failure to write media file?

I’m setting up a new system, and I’ve been chugging along for a couple of days adding new items and pictures to the collection. No issues at all, I’ve been loving it.

Then today, suddenly it stopped. It won’t let me upload any more media files. Occasionally it says “Omeka-S has encountered an error,” but usually it gives me a red banner that says “Failed to write file to disc.” I’ve cleared the cache on my browser, and I’ve rebooted the server.

I’ve only got 208 items in the collection so far, and not all of them have images attached. Can anybody else provide some insight where to look to fix this problem?

Thanks in advance.

Further information:

Omeka-S v2.1.0 is running on Ubuntu 16 with Apache2, php 7.4.3, MySQL 5.7.29

FTP file transfers into the server work fine.

CollectionSpace is also running on this server and has also suddenly decided to stop writing media files. CollectionSpace uses Tomcat, PostgreSQL, and a different internet port. They’ve been playing nice, but it seems like whatever the problem is, must be in something they share.

Ok, I think I fixed it, but I’m still not sure why. I resized the disk space, and now it works. But if I was really out of disk space on the server, why could I still FTP a file in??

I’m not sure of your server’s setup, but it’s possible that Omeka and other web content is being stored in a different filesystem than the one you were FTP-ing into, and only one was full? Or it could simply be a difference in file size between what you were trying to upload one way versus the other.

It was the same file that I tried to upload in all three ways. And I only have one partition on my server. Just weird.