Faceted Browse Facets Not Showing on Advanced Search page


I have just noticed an issue with the use of Faceted Browse on my Advanced Search page (Advance Search Page). For some reason, it no longer displays the searchable facets. I have not made any changes to the module src files, have tried removing all my custom CSS changes, and the only module I have installed since they disappeared was the ‘Common’ module which I was advised to install following the advice given here:

Is there a way for me to troubleshoot this error to find out what may be causing this issue? I have tried looking at the Inspect and Page Source of my browser but cannot find the root cause.

Thank you to anyone for help with this matter.

Best Wishes,


I am encountering an issue where my faceted browse module is not working in tandem with my advanced search page. It works correctly when I create custom faceted browse pages (Herbarium Histories · Correspondence · Omeka), but this does not work when I apply it to my default advanced search page (Herbarium Histories · Search · Omeka). I have tried removing all custom CSS formatting for the advanced search page and have also tried reverting my server files, but still cannot find any reason for the Faceted Browse filters not appearing.

Has anyone encountered this issue before?

I believe those are just two different modules that don’t work together. Both Faceted Browse and Advanced Search create their own independent custom browse/search pages. Do you really need both?

I was planning to use the Advanced Search page as a foundation for the search functionality of my Omeka S website (with custom Advanced Form Filters), and then my intention for Faceted Browse was for it to be used as a refining tool for the subsequent search results. An example I was looking at where this works is the New Jersey Slavery Records (https://records.njslavery.org/s/doc/find), which uses both the Advanced Search page as well as Faceted Browse for this exact purpose.

As mentioned, Faceted Browse is working correctly on custom pages, but for some reason, is not interacting with the Advanced Search page successfully. Moreover, it was previously working as intended before this ‘No Facets’ bug appeared…

Do you have any advice on why it may have broken and how to go about fixing it? Or if possible, another means for achieving this desired search capability?

Hi @weaverfish1! I believe what @jflatnes said is correct: those two modules work independently of each other, and the settings for their facets are separate.

On my New Jersey Slavery Records site, these two modules do not interact with each other. Most of my site’s functionality is delivered using the Faceted Browse module, such as the Events and Persons browsing pages.

The Advanced Search page that’s in the navigation menu is built on the Advanced Search module, and the facets that show up on it are configured separately from the Events, Persons and other Faceted Browse module pages. I have been experimenting with the Advanced Search page, but I have not really optimized it for usability. And I decided to work on improving my Faceted Browse pages instead. I’m probably going to remove my Advanced Search page and replace it with a simple search form to avoid confusing the users with multiple different faceted layouts.

So, to @jflatnes’s question “do you really need both?” I don’t know about you, but for me, the answer is probably “no.” I think it is good to experiment with both modules to see what works best for your site and then select one of them. I find for my needs, Faceted Browse is more useful because it delivers a more curated experience for the user, and it provides the ability to show data in columns, which is very important for me.

If you’re trying to troubleshoot the Advanced Search module, here are screenshots from my Advanced Search settings (configuration for this page https://records.njslavery.org/s/doc/find). Do you still have anything listed in the “List of facets” section or did the codes get deleted from that box?