Error Zend_Db_Adapter_Exception

Hi.

I am trying to install Omeka classic but I get the following error
Fatal error : Uncaught Zend_Db_Adapter_Exception: Configuration array must have a key for ‘username’ for login credentials in
/srv/disk5/3553005/www/pehmalaga.atwebpages.com/application/libraries/Zend/Db/Adapter/Abstract.php:304 Stack trace: #0 /srv/disk5/3553005/www/pehmalaga.atwebpages.com/application/libraries/Zend/Db/Adapter/Abstract.php(184): Zend_Db_Adapter_Abstract->_checkRequiredOptions(Array) #1 /srv/disk5/3553005/www/pehmalaga.atwebpages.com/application/libraries/Zend/Db.php(270): Zend_Db_Adapter_Abstract->__construct(Array) #2 /srv/disk5/3553005/www/pehmalaga.atwebpages.com/application/libraries/Omeka/Application/Resource/Db.php(62): Zend_Db::factory(‘Mysqli’, Array) #3 /srv/disk5/3553005/www/pehmalaga.atwebpages.com/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(695): Omeka_Application_Resource_Db->init() #4 /srv/disk5/3553005/www/pehmalaga.atwebpages.com/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(638): Zend_Application_Bootstrap_BootstrapAbstract->_executeRes in /srv/disk5/3553005/www/pehmalaga.atwebpages.com/application/libraries/Zend/Db/Adapter/Abstract.php on line 304

I have tried it on multiple servers but I get the same error.
However, locally with Xampp it works perfectly

This is just telling you that you don’t have the “db.ini” file fully filled in. Specifically it’s complaining about the “username” not being filled in.

Thank you very much. It was indeed about that. In the original db.ini it put “user” instead of “usename”.

However now in encountered the following error:

Schema task failed on table ‘omeka_collections’ with Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : The ‘InnoDB’ feature is disabled; you need MySQL built with ‘InnoDB’ to have it working

The database supports Innodb.

I’m not sure exactly what the issue is, but it’ll be something about your MySQL server’s configuration, maybe you have InnoDB disabled or set to read-only or something like that?

All we do is try to create InnoDB tables, so if MySQL is failing with this message, it must be an issue on that end.