Error Updating to 3.2.x from 2.1.2 - Installatron, Reclaimhosting

We have been having an issue where the banners for the pages (e.g. the Home, About, etc) do not show up to users browsing the site. They do load when we are logged in to the site admin account. Thumbnails under Browse load fine, and the images for each item page also load fine. (Theres a problem with the database migrations possibly, and I can post some seemingly related stack traces if you like. However, there seem to be multiple issues so this thread will initially focus on our installatron error).

The Omeka S site will not automatically upgrade via installatron and throws the following error:

Error: 2022-10-07 13:10:34.40482900 FAILURE [3; /bin/curl] Omeka S [http code=404. Request: /var/installatron/cache/fetch_query_44fcc10546054b34dc3641de87f73dd6.part; Headers: /var/installatron/cache/fet

I have referred to Installing - Omeka S User Manual and tried:
testing and setting php path on reclaim hosting as well as these instructions on updating manually which I tried to do through cPanel file manager. This did not fix the issue with the images not loading, and cPanel/installatron couldn’t tell that it had been updated (still showed old version). I realize those updating manually instructions probably (?) aren’t meant for installatron but for someone self-hosting.

Anyway, I later installed a fresh install of 3.2.0 through installatron and simply copied all the files into the new install and pointed it to a cloned database of the original site. However, the original issue we were trying to fix persisted, so I’m thinking the issue is in the tables. Installatron also didn’t recognize that there were files copied in and still showed the empty install file tree size.

Any insight into the problem is appreciated.