Error message when trying to upload a file

I’m having a problem when trying to upload files to my Omeka site. I am able to add item information, but when I attempt to attach a file I receive the message - “There was an error on the form. Please try again.” I’ve tried different types of files (pdf, mp3, jpeg) and nothing works. This only started happening after I attempted to download the EADImporter Plugin. I tried to download that plugin and that gave a fatal error, and everything crashed. So I removed the files from my server, and I was able to get back into the Admin site. But now there’s a pesky red “This is not a valid plugin” bar showing up on my list of plugins.

I do not know if these the errors are related? But, in any case, I still can’t upload new files to my site. Any advice on how to fix this?

The “not a valid plugin” error shouldn’t affect anything else.

So, you only encounter this problem when you try to upload a file, not when doing anything else?

Yes, I am able to save information about the item - but can’t upload a file. I seem to only get the error message when I try to attach a file.

Is the file you’re trying to upload fairly large? Sometimes you can end up with misleading error messages when you try to upload something that exceeds PHP’s post_max_size, an internal setting for how much data you can send to PHP in one request.

No, its a typical size that I’ve loaded before. I also tried a couple different files of various file types - and nothing is working. (In the past if I’ve tried to load a file that is too large I received a message telling me so.)

Can you tell me what Omeka’s reporting as the maximum file size you’re allowed to upload (visible near the upload input)?

This is a strange problem because file uploads themselves shouldn’t result in the message you’re getting, so something else is at work here…

What is the version of your plugin? Did you rename its folder?

Hello: we are receiving the same error message, specifically when trying to upload oral histories to our site, which is I would appreciate any guidance. There seems to be no solution in this thread.

Do you know what the maximum file size is for your server? Oral histories files can be very large and they may be maxing out what is set at the server level. The maximum file size you’re allowed to upload is visible near the file upload input.

Hi: I just changed the maximum file size from 10M to 250M in config.ini
Unfortunately, we are still getting the same error message.

This post might helpful for the server administrator, since it needs to be changed in a couple of places: Increasing file size limit?

There’s some misinformation floating around, so here’s the end-all, be-all of file size setting information for Omeka Classic:

  1. The upload.maxFileSize limit in Omeka’s application/config/config.ini is only useful for decreasing the limit, not for increasing it. It’s there if you want to restrict uploads in Omeka more than your PHP settings mandate. It’s not set at all by default, and if you don’t have it set already, it plays no role in increasing the upload maximum size.

  2. The php.ini setting upload_max_filesize is a limit set by PHP that constrains the maximum size of any one file. If this is smaller than a file you want to upload, you need to increase it.

  3. The php.ini setting post_max_size is a limit set by PHP that constrains the maximum total amount of data that can be sent in any one request. This includes uploaded files as well as any regular form data (the contents of text inputs and textareas, for example).

    This must be set at least as large as upload_max_filesize for that setting to have any effect, and generally should be larger, to allow for some data to be sent alongside a large file and/or to allow multiple large files to be uploaded at once.

Omeka will read all three of these settings and report to you what the largest file size you can upload is, immediately above the “Find a file” prompt on the Files tab.

Of these three, it’s most often post_max_size that’s the problem, as PHP has some odd behaviors when you exceed that limit which can make the cause of the error a little less obvious. The others tend to give you fairly clear error messages.

With help from our Server Managers at Reclaim, we changed the upload_max_filesize in cPanel>PHP Selector to 258M. We also turned on “detailed error messages.”

Today, when trying to upload the large audio files, my project manager is still encountering the original problem: “There was an error on the form. Please try again.”

In addition, he has encountered two new error messages. These messages are appearing on the public version of the site, not just on the administration page.

Can you offer any guidance related to these error messages? Are these “new” or are they a further explanation of the original issue?

Public site error (in Firefox):
Notice: Undefined variable: bodyclass in /home/deniseme/public_html/ on line 5

Back end site error (in Chrome):
Strict Standards: Declaration of SimpleVocabPlus_Controller_Plugin_Autosuggest::preDispatch() should be compatible with Zend_Controller_Plugin_Abstract::preDispatch(Zend_Controller_Request_Abstract $request) in /home/deniseme/public_html/ on line 0

You’re seeing those new ones because you turned on detailed error display. They’re unrelated.

Can you just confirm, what does Omeka say right above the file upload box? It should tell you what we think the current limit is.