Error linking files in Dropbox

Here’s a perplexing issue:

I’ve uploaded a number of large (1-5 GB) video files to the server using filezilla. The files are in /dropbox/files.

I go to an existing item (1.4 GB), click on the Files tab, then select the correct video to go with the item.

I click Save Changes.

The progress loop spins and spins and spins.

About 15 minutes later I get this error:


/admin/items/edit/15 is not a valid URL."

Roughly the same thing happens if I try to do a batch add from the Dropbox plugin page. I select several items, click Upload Files as Items, and wait. And wait. And wait. And then get the same error:


/admin/dropbox/index/add is not a valid URL.

Strangely, this worked once, with the largest file I uploaded–4.7 GB.

Is there some sort of file transfer happening on the server that is then causing the server to error out?

Is Dropbox actually adding these huge files to a mysql record instead of a pointer to it?

Any insight would be most appreciated.



This evening I received email from my domain server host telling me I had generated four large files in their /tmp folder. They all look more or less like this: /tmp/b2004fd0ff0c84fd96161e78894d9bfb.mp4.

When I looked at my /tmp directory, there were no such files, so I asked the tech where to find them. She replied:

"The /tmp is an absolute path that represents the server level temporary directory. It’s not the same directory as your account’s temporary directory which has it’s absolute path under /home/USERNAME/tmp.

If these files were the result of an upload via a specific script, they can be removed with the same script."

So it seems that Dropbox is moving these large files from one directory (/plugins/dropbox/files) to somewhere else…but they get dropped somewhere along the way and abandoned. The tech seems to be suggesting that Dropbox could be designed to see those root-based /tmp files and do something with them, but I’m guessing it doesn’t at present.

Does this help anyone understand what’s going on here?

If not, does anyone know how to link a large video file to an item?

Thanks in advance for using some of your brain cells on a problem I produced all by myself.


Hmmm. Is this issue so complex that everyone’s at a loss, or am I so dumb that everyone’s waiting for me to RTFM (which I did, unproductively).

I’m surprised others haven’t encountered this issue. Surely I’m not the only Omeka user who’s managing large video files. Any oral historians out there who are archiving hour+ long recordings?

Fingers crossed…


Drat. I guess the Omeka Forum’s dying out.


This issue is not related to Omeka, but to your server. Your provider doesn’t allow too big files in the temp directory, or you have no space left.

Thanks for the suggestion, Daniel. If that’s the case, why would it have worked once? Is this something I can ask to have changed? If so, do I simply ask for a larger /tmp directory allocation?

How do other people deal with large files in Omeka? I can believe this is an unusual use for the system…

Thanks for you help!


It probably worked as long as there is free space. Video are big files. Check the free space and if temp video files weren’t removed.