Error 500 for admin dashboard

Hello, I just completed an install of Omeka for my site, but after seeing the successful installation message I tried to open the admin dashboard and got an error 500 message with no further explanation. What could be causing this? The public site just gives the message “Public site is unavailable until the upgrade completes.” Please help. Thank you in advance.

You are seeing the 500 error when you go to What happens if you go to /install?

It says “Success!” and gives me the two options “Public Site” and “Admin Dashboard.” When I click on the latter, the error 500 page comes up.

Do you get something more useful as an error message if you follow these instructions for turning on error display?

I turned it on and it said that the server is unable to handle the request. I tried debugging it too to no avail.

Another thing: When I type in it redirects me to /admin/upgrade

Is that normal?

No. The behavior you’re describing from the front and back ends is what Omeka does when there’s an upgrade that needs to be applied, but this shouldn’t happen right after an install. You might want to clear out the database (or create a new one and point the db.ini at that new one) and try installing again.

So I should drop all the omeka files and reupload them? It already appears that they are in their own database.

anyway, I tried reinstalling omeka. Now when I try to access the /install page it says ‘connection refused.’

Any idea why this is?

edit: After reinstalling again, the same message still popped up. Is it because I already made a super user account on the very first install before uninstalling that? I thought it would be wiped.

Can you take a screenshot?

“Connection refused” isn’t a common Omeka error that I’m aware of.

If you erased the database then nothing that Omeka S installed will have remained, including the initial user account.

can you please clarify what you want a screenshot of?

The error you’re seeing.

edit: when I do /admin it gives me the ‘internal server error’ message

I went ahead and updated to omeka 2.7 and now get this message when i tried to finish the install:

" Fatal error: Uncaught exception ‘Zend_Db_Adapter_Mysqli_Exception’ with message ‘Connection refused’ in /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Zend/Db/Adapter/Mysqli.php:340 Stack trace: #0 /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Zend/Db/Adapter/Mysqli.php(549): Zend_Db_Adapter_Mysqli->_connect() #1 /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Omeka/Db.php(322): Zend_Db_Adapter_Mysqli->getServerVersion() #2 /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Omeka/Db.php(56): Omeka_Db->_getInitCommand() #3 /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Omeka/Application/Resource/Db.php(64): Omeka_Db->_construct(Object(Zend_Db_Adapter_Mysqli), 'omeka’) #4 /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(695): Omeka_Application_Resource_Db->init() #5 /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Zend/Application/Bootstrap/BootstrapA in /hermes/walnaweb03a/b103/im.pilkguns/museum/application/libraries/Zend/Db/Adapter/Mysqli.php on line 340 "

Is the connection information in your db.ini file correct? In particular the host, as it seems Omeka’s not even able to start connecting to your database server (this error is happening at a lower, earlier level than common problems with usernames and passwords).

In general, you’re getting a lot of errors that don’t really align with ones we normally see people encountering

The information should be correct, but I am not 100% positive. However, I could try contacting the host to double check. If it turns out that the information in the db file was incorrect, and then correct connection info is put in, should it work?

The zend & db issues were fixed, but now, once again, I cannot access the admin dashboard because it redirects me to admin/upgrade where the link 404’s.

I am still interested in finding a solution to this.

Also I got the ‘connection reset’ error.