ERROR 403 - FORBIDDEN : Universal Viewer

Hi,
I am new in Omeka. Installed Omeka-S and trying to explore the modules III Server and universal viewer to view 3D models. However, no luck with UV with any media file. Getting black screen with ‘ERROR 403 - FORBIDDEN’.

For example:


Can anyone please advise/help, what to do?
Thanks.

The viewer works and all files of the item and of the viewer are available: http://omeka.bdheritage.org/modules/UniversalViewer/asset/vendor/uv/app.html?isHomeDomain=true&isOnlyInstance=true&manifestUri=http%3A%2F%2Fomeka.bdheritage.org%2Fiiif%2F29%2Fmanifest#?c=0&m=0&s=0&cv=0, so it seems to be an issue with the server or it may be a particular config. Do you use something specific?

1 Like

WoW !!!
Thanks Daniel, it looks great. I am new with Omeka, and trying to develop a portal of 3D models. I have not changed any settings/config file except, .htaccess file, which has been suggested by IIIF Server module page.

CORS access for some files.

<FilesMatch “.json$”>

Header add Access-Control-Allow-Origin "*"
Header add Access-Control-Allow-Headers "origin, x-requested-with, content-type"
Header add Access-Control-Allow-Methods “GET, POST, OPTIONS”

Is there anything I need to do in the server? or change any settings inside OMEKA-S ? Thanks in advance for your help.

Hafiz

In fact, the full url of the iframe is http://omeka.bdheritage.org/modules/UniversalViewer/asset/vendor/uv/app.html?isHomeDomain=true&isOnlyInstance=true&manifestUri=http%3A%2F%2Fomeka.bdheritage.org%2Fiiif%2F29%2Fmanifest&embedScriptUri=http://omeka.bdheritage.org/modules/UniversalViewer/asset/vendor/uv/lib/embed.js?v=3.5.7&embedDomain=omeka.bdheritage.org&domain=omeka.bdheritage.org&isLightbox=false&locale=en-GB:English%20(GB),fr:French&config=/themes/default/asset/universal-viewer/config.json?v=1.1.0&xdm_e=http%3A%2F%2Fomeka.bdheritage.org%2Fs%2Ffree3Dmodels%2Fitem%2F29&xdm_c=default1910&xdm_p=4

It seems to be an issue with the ?v=3.5.7 in the full url of the iframe. If you remove it manually from the url above, the viewer work. It seems to be an issue in the module, since this part of the url is not “url encoded”. I’m checking it.

1 Like

Thanks Daniel,
I can pass you the admin ID and Password of Omeka-S, if you like.

I published release 3.5.8, so you can try it: https://github.com/Daniel-KM/Omeka-S-module-UniversalViewer/releases

1 Like

That’s great. I am trying this updated version and let you know soon. Thanks again for your prompt support.

Hi Daniel,
Fantastic !!! Its working great !!!
Thanks a lot for your support.

Cheers :slight_smile: