ERR (3): Command "command -v 'php'"


I have tried everything to get the CSVImport to work, but always get the same error in the log. the message is: ERR (3): Command “command -v ‘php’” failed with status code 1

Are the CLi settings or something I need to set first? I tried the same file import on the omeka sandbox, worked without problems.

anyone got any suggestions?

You can set the full path to php in your config/local.config.php in the line:

    'cli' => [
        'phpcli_path' => null,

Hi Daniel,
thanks, I have tried adding the path, but get a blank screen then. Not sure if my syntax is wrong…

This is the path entered: /usr/local/php7/bin/php-cli

Correct or needs a change?


We can’t know for you what is the correct path of your PHP CLI.

What operating system do you use?

Try the path typing /usr/local/php7/bin/php-cli -a in a shell, you will see if it works (PHP CLI well starts) or not.

Besides, ensure you’ve put the path between quotes in your config file.

'phpcli_path' => '/usr/local/php7/bin/php-cli',