Dspace connector error


#1

Hi All,

I am quite new to Omeka S and am having an issue with the DSpace connector. I am trying to connect to this item:

http://dr.library.brocku.ca/handle/10464/13754

But when I try to connect I get the “There was an error during validation” message.
Any help would be greatly appreciated.

EDIT: I am now receiving a “There was an error retrieving data. Please try again.” message. Not sure if this is progress

Thank you,

Daniel Brett


#2

Anybody have any Ideas?


#3

Are you entering the URL you gave in your first post into the connector’s form, or something else?

The usual API endpoint of /rest at the server you linked to seems to be inaccessible, so this could just be a sever-side issue on the remote end.


#4

So the issue is with the target repository? Hmm. I will have to talk to our server guy and see if he can figure it out then.

Thank you so much for the response!!

Daniel Brett

P.s. This is what I was trying


#5

I think to start out, you want to just have the base URL of the site in that first box, so just the domain name.


#6

Ok I tried it with just the domain name but there is nothing here. Both the Collections and Communities tabs are empty. Does this imply that your previous thought about the issue being on the repository’s end was correct?

Thank you!

Daniel


#7

I have now tried connecting to other parts of the repository and it is still returning either an error

There was an error retrieving data. Please try again.

or blank collections and communities tabs. Any further insights @jflatnes?

Thanks,

Daniel


#8

Have you checked with the server’s administrators? From what I can tell the /rest API endpoint just doesn’t work on that server.


#9

Alright I will check with them now that I have something specific to ask. Sorry to for the silly questions. I am still very new at this. You have been exceptional!

Thanks,

Daniel