Difficulty installing plugins

For the past three weeks I have been trying to install Simple Bookmarking plugin into my website. My last attempt include creating a new FTP account, installing the plugin into the FTP account via Cyberduck and via Cpanel/Files/File Manager/FTP account. Despite all this, I still cannot see the plugin on the Omeka admin dashboard and therefore unable to install same. Thanks for any and all support/advice/recommendations.

The module is Social Bookmarking that you’re trying to install?

Ultimately, installing a module means getting the module’s folder into the installation’s plugins folder. Is that what you’ve done?

Screenshots from one of your interfaces used to manage your files might be helpful in demonstrating what you’ve tried.

Here is the screenshot of where I am currently.

As you can see, you do not have a folder named “SocialBookmarking” there, but just a file.
I wonder whether that’s the compressed file for the plugin, in which case you should first uncompress it on your local computer and then reupload the uncompressed folder (with all its files inside).

I have tried again to install the plugin ‘SocialBookmarking’ using both Cyberduck and uploading the individual files via the FTP Files Manager. Both folders are visible in Cyberduck and in FTP Manager. On the Omeka site admin dashboard it says that the plugin is not valid.

My last post on plugins 14 days ago has gone unanswered. I am posting this new issue on the unresolved question on plugins in Omeka Classic. I am not seeing my web portal on Cyberduck, hence the question is if this issue is occurring at Omeka’s end?

When the dashboard says “Not a valid plugin” it means there’s a problem with either the folder structure for the plugin, or the file permissions.

Another screenshot, this time inside the SocialBookmarking folder, might help.

So I installed 18 plugins into my Omeka Classic all of which are working except Geolocation and SocialBookmarking. Attached is a screenshot inside the SocialBookmarking folder in Cyberduck.

So, last we talked about this you just had the three built-in plugins there in the plugins folder. So you’ve been able to install a bunch of other plugins since then but just not these specific two?

Have you tried just completely deleting the SocialBookmarking folder, everything you have up on the server for it, and trying again with a fresh copy?

Hi John,
As you mentioned about deletion of SocialBookmarking folder completely from the server, yes I did (up to this morning, actually) and reloaded but the obstacle still exists. Since you’ve also mentioned additional plugins there are details that I would comment on and on each specifically -

  • Geolocation - working fine up to a point. According to the documentation I should be able to add more locations manually but this option is not working

  • Embed Code - Unable to embed in admin though the documentation says that a box for code should appear. But when viewing the public page the Embed Code box appears with a pre-built code. When replacing that with my code I do not get the expected results.


Can you try using this copy of the SocialBookmarking zip instead? There’s a small change to that zip file, I’m not sure if it’s relevant to the problem you’re having but it’s worth a try.

Hi John,
Not sure if this copy works, the social media option is not available when uploading new items, as per the documentation, however it is active on the Omeka admin page and executable.


Can you show where you’re expecting to see the social links that you’re not?

The Social Bookmarking stuff doesn’t show on the admin side at all, since it’s only intended to be used by visitors to the site.